it's buggy #13

by hjjhg - opened

first i get black image. after that i get just noise. now images are pixelated with small squares. sometimes whole images and sometimes one part of image.
all other models i tested are working perfectly without one single bug. i never experienced a bug until this 2.1 model. with all other models i can make 1080p images but with this one i can't because video memory is full. pls fix this 馃檪

Hey could you please update your diffusers version?

it is updated.

@hjjhg Have you tried this tutorial? It helped me with the same problem.
Pay attention to the command line argument: --no-half

stabilityai/stable-diffusion-2-1 路 [Tutorial] How to use Stable Diffusion V2.1 and Different Models in the Web UI - SD 1.5 vs 2.1 vs Anything V3
https://huggingface.co/stabilityai/stable-diffusion-2-1/discussions/15

same here. getting this on both ema and nonema, tested both safetensors and ckpt files ... any fix ... launched with : set COMMANDLINE_ARGS=--xformers --vae-path "F:\stable-diffusion-webui\models\VAE\vae-ft-mse-840000-ema-pruned.pt" --no-half --no-half-vae --precision full

no longer an issue. incorrect xformers wheel and cuda kit

I notice yesterday that using multiple brackets to change words weight seems to be an issue regarding bad image with little square in background. Sometimes, sing blurred and faded background seems to get the entire image bad. Using embedding seems to help with all of that. Hope this info help you have better images.

Same issue here, all images generated look like this:

@georgep4181 How were you able to resolve the incorrect xformers wheel?

image.png

you don't need xformers anymore with the new torch 2.0

yesterday I tried deforum stable difussion to do videos for the first time. The first 2 worked fine.... then, I suddenly started getting "black"(flat images with weird textures) frames after the first one (second frame and on).... i changed browsers, same bug... any idea how to solve it'? Im using cuda.

Sign up or log in to comment