Spaces:
Detic
Runtime error

runtime error

Space not ready. Reason: Error, exitCode: 1, message: None

Container logs:

					
						Defaulting to user installation because normal site-packages is not writeable
Collecting gradio==2.4.6
  Downloading gradio-2.4.6-py3-none-any.whl (979 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 979.1/979.1 KB 69.7 MB/s eta 0:00:00
Collecting Flask-Cors>=3.0.8
  Downloading Flask_Cors-3.0.10-py2.py3-none-any.whl (14 kB)
Collecting flask-cachebuster
  Downloading Flask-CacheBuster-1.0.0.tar.gz (3.1 kB)
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Collecting Flask-Login
  Downloading Flask_Login-0.6.2-py3-none-any.whl (17 kB)
Requirement already satisfied: numpy in /home/user/.local/lib/python3.8/site-packages (from gradio==2.4.6) (1.23.4)
Requirement already satisfied: pandas in /home/user/.local/lib/python3.8/site-packages (from gradio==2.4.6) (1.5.1)
Collecting markdown2
  Downloading markdown2-2.4.6-py2.py3-none-any.whl (37 kB)
Requirement already satisfied: pillow in /home/user/.local/lib/python3.8/site-packages (from gradio==2.4.6) (9.2.0)
Requirement already satisfied: matplotlib in /home/user/.local/lib/python3.8/site-packages (from gradio==2.4.6) (3.6.1)
Requirement already satisfied: paramiko in /home/user/.local/lib/python3.8/site-packages (from gradio==2.4.6) (2.11.0)
Requirement already satisfied: analytics-python in /home/user/.local/lib/python3.8/site-packages (from gradio==2.4.6) (1.4.0)
Requirement already satisfied: pycryptodome in /home/user/.local/lib/python3.8/site-packages (from gradio==2.4.6) (3.15.0)
Requirement already satisfied: pydub in /home/user/.local/lib/python3.8/site-packages (from gradio==2.4.6) (0.25.1)
Collecting Flask>=1.1.1
  Downloading Flask-2.2.2-py3-none-any.whl (101 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 101.5/101.5 KB 29.0 MB/s eta 0:00:00
Requirement already satisfied: ffmpy in /home/user/.local/lib/python3.8/site-packages (from gradio==2.4.6) (0.3.0)
Requirement already satisfied: requests in /home/user/.local/lib/python3.8/site-packages (from gradio==2.4.6) (2.28.1)
Requirement already satisfied: click>=8.0 in /home/user/.local/lib/python3.8/site-packages (from Flask>=1.1.1->gradio==2.4.6) (8.0.4)
Collecting Werkzeug>=2.2.2
  Downloading Werkzeug-2.2.2-py3-none-any.whl (232 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 232.7/232.7 KB 37.6 MB/s eta 0:00:00
Requirement already satisfied: importlib-metadata>=3.6.0 in /home/user/.local/lib/python3.8/site-packages (from Flask>=1.1.1->gradio==2.4.6) (5.0.0)
Requirement already satisfied: Jinja2>=3.0 in /home/user/.local/lib/python3.8/site-packages (from Flask>=1.1.1->gradio==2.4.6) (3.1.2)
Collecting itsdangerous>=2.0
  Downloading itsdangerous-2.1.2-py3-none-any.whl (15 kB)
Requirement already satisfied: Six in /home/user/.local/lib/python3.8/site-packages (from Flask-Cors>=3.0.8->gradio==2.4.6) (1.16.0)
Requirement already satisfied: backoff==1.10.0 in /home/user/.local/lib/python3.8/site-packages (from analytics-python->gradio==2.4.6) (1.10.0)
Requirement already satisfied: monotonic>=1.5 in /home/user/.local/lib/python3.8/site-packages (from analytics-python->gradio==2.4.6) (1.6)
Requirement already satisfied: python-dateutil>2.1 in /home/user/.local/lib/python3.8/site-packages (from analytics-python->gradio==2.4.6) (2.8.2)
Requirement already satisfied: charset-normalizer<3,>=2 in /home/user/.local/lib/python3.8/site-packages (from requests->gradio==2.4.6) (2.1.1)
Requirement already satisfied: certifi>=2017.4.17 in /home/user/.local/lib/python3.8/site-packages (from requests->gradio==2.4.6) (2022.9.24)
Requirement already satisfied: idna<4,>=2.5 in /home/user/.local/lib/python3.8/site-packages (from requests->gradio==2.4.6) (3.4)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in /home/user/.local/lib/python3.8/site-packages (from requests->gradio==2.4.6) (1.26.12)
Requirement already satisfied: kiwisolver>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->gradio==2.4.6) (1.4.4)
Requirement already satisfied: packaging>=20.0 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->gradio==2.4.6) (21.3)
Requirement already satisfied: cycler>=0.10 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->gradio==2.4.6) (0.11.0)
Requirement already satisfied: pyparsing>=2.2.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->gradio==2.4.6) (3.0.9)
Requirement already satisfied: contourpy>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->gradio==2.4.6) (1.0.5)
Requirement already satisfied: fonttools>=4.22.0 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->gradio==2.4.6) (4.38.0)
Requirement already satisfied: pytz>=2020.1 in /home/user/.local/lib/python3.8/site-packages (from pandas->gradio==2.4.6) (2022.5)
Requirement already satisfied: cryptography>=2.5 in /home/user/.local/lib/python3.8/site-packages (from paramiko->gradio==2.4.6) (38.0.1)
Requirement already satisfied: pynacl>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from paramiko->gradio==2.4.6) (1.5.0)
Requirement already satisfied: bcrypt>=3.1.3 in /home/user/.local/lib/python3.8/site-packages (from paramiko->gradio==2.4.6) (4.0.1)
Requirement already satisfied: cffi>=1.12 in /home/user/.local/lib/python3.8/site-packages (from cryptography>=2.5->paramiko->gradio==2.4.6) (1.15.1)
Requirement already satisfied: zipp>=0.5 in /home/user/.local/lib/python3.8/site-packages (from importlib-metadata>=3.6.0->Flask>=1.1.1->gradio==2.4.6) (3.10.0)
Requirement already satisfied: MarkupSafe>=2.0 in /home/user/.local/lib/python3.8/site-packages (from Jinja2>=3.0->Flask>=1.1.1->gradio==2.4.6) (2.1.1)
Requirement already satisfied: pycparser in /home/user/.local/lib/python3.8/site-packages (from cffi>=1.12->cryptography>=2.5->paramiko->gradio==2.4.6) (2.21)
Building wheels for collected packages: flask-cachebuster
  Building wheel for flask-cachebuster (setup.py): started
  Building wheel for flask-cachebuster (setup.py): finished with status 'done'
  Created wheel for flask-cachebuster: filename=Flask_CacheBuster-1.0.0-py3-none-any.whl size=3372 sha256=ffae22efdf6dedbec070d416452ac5601a537ed9f5dc26aceaa58488e504d600
  Stored in directory: /home/user/.cache/pip/wheels/27/1b/de/34a3e06893944387266e2e7e93d33243589f01ac1b451e367b
Successfully built flask-cachebuster
Installing collected packages: Werkzeug, markdown2, itsdangerous, Flask, Flask-Login, Flask-Cors, flask-cachebuster, gradio
  Attempting uninstall: gradio
    Found existing installation: gradio 2.9.0.1
    Uninstalling gradio-2.9.0.1:
      Successfully uninstalled gradio-2.9.0.1
Successfully installed Flask-2.2.2 Flask-Cors-3.0.10 Flask-Login-0.6.2 Werkzeug-2.2.2 flask-cachebuster-1.0.0 gradio-2.4.6 itsdangerous-2.1.2 markdown2-2.4.6
WARNING: You are using pip version 22.0.2; however, version 22.3 is available.
You should consider upgrading via the '/usr/local/bin/python -m pip install --upgrade pip' command.
Defaulting to user installation because normal site-packages is not writeable
Looking in links: https://dl.fbaipublicfiles.com/detectron2/wheels/cu102/torch1.9/index.html
DEPRECATION: The HTML index page being used (https://dl.fbaipublicfiles.com/detectron2/wheels/cu102/torch1.9/index.html) is not a proper HTML 5 document. This is in violation of PEP 503 which requires these pages to be well-formed HTML 5 documents. Please reach out to the owners of this index page, and ask them to update this index page to a valid HTML 5 document. pip 22.2 will enforce this behaviour change. Discussion can be found at https://github.com/pypa/pip/issues/10825
Collecting detectron2
  Downloading https://dl.fbaipublicfiles.com/detectron2/wheels/cu102/torch1.9/detectron2-0.6%2Bcu102-cp38-cp38-linux_x86_64.whl (6.4 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 6.4/6.4 MB 8.4 MB/s eta 0:00:00
Requirement already satisfied: tabulate in /home/user/.local/lib/python3.8/site-packages (from detectron2) (0.9.0)
Requirement already satisfied: matplotlib in /home/user/.local/lib/python3.8/site-packages (from detectron2) (3.6.1)
Requirement already satisfied: cloudpickle in /home/user/.local/lib/python3.8/site-packages (from detectron2) (2.2.0)
Requirement already satisfied: tqdm>4.29.0 in /home/user/.local/lib/python3.8/site-packages (from detectron2) (4.64.1)
Requirement already satisfied: Pillow>=7.1 in /home/user/.local/lib/python3.8/site-packages (from detectron2) (9.2.0)
Collecting tensorboard
  Downloading tensorboard-2.10.1-py3-none-any.whl (5.9 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 5.9/5.9 MB 118.8 MB/s eta 0:00:00
Requirement already satisfied: future in /home/user/.local/lib/python3.8/site-packages (from detectron2) (0.18.2)
Requirement already satisfied: yacs>=0.1.8 in /home/user/.local/lib/python3.8/site-packages (from detectron2) (0.1.8)
Collecting pydot
  Downloading pydot-1.4.2-py2.py3-none-any.whl (21 kB)
Collecting black==21.4b2
  Downloading black-21.4b2-py3-none-any.whl (130 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 131.0/131.0 KB 37.1 MB/s eta 0:00:00
Requirement already satisfied: fvcore<0.1.6,>=0.1.5 in /home/user/.local/lib/python3.8/site-packages (from detectron2) (0.1.5)
Requirement already satisfied: omegaconf>=2.1 in /home/user/.local/lib/python3.8/site-packages (from detectron2) (2.3.0.dev1)
Collecting pycocotools>=2.0.2
  Downloading pycocotools-2.0.5.tar.gz (24 kB)
  Installing build dependencies: started
  Installing build dependencies: finished with status 'done'
  Getting requirements to build wheel: started
  Getting requirements to build wheel: finished with status 'done'
  Preparing metadata (pyproject.toml): started
  Preparing metadata (pyproject.toml): finished with status 'done'
Collecting iopath<0.1.10,>=0.1.7
  Downloading iopath-0.1.9-py3-none-any.whl (27 kB)
Requirement already satisfied: hydra-core>=1.1 in /home/user/.local/lib/python3.8/site-packages (from detectron2) (1.3.0.dev0)
Requirement already satisfied: termcolor>=1.1 in /home/user/.local/lib/python3.8/site-packages (from detectron2) (2.0.1)
Requirement already satisfied: regex>=2020.1.8 in /home/user/.local/lib/python3.8/site-packages (from black==21.4b2->detectron2) (2022.9.13)
Requirement already satisfied: toml>=0.10.1 in /home/user/.local/lib/python3.8/site-packages (from black==21.4b2->detectron2) (0.10.2)
Requirement already satisfied: click>=7.1.2 in /home/user/.local/lib/python3.8/site-packages (from black==21.4b2->detectron2) (8.0.4)
Collecting appdirs
  Downloading appdirs-1.4.4-py2.py3-none-any.whl (9.6 kB)
Collecting pathspec<1,>=0.8.1
  Downloading pathspec-0.10.1-py3-none-any.whl (27 kB)
Collecting mypy-extensions>=0.4.3
  Downloading mypy_extensions-0.4.3-py2.py3-none-any.whl (4.5 kB)
Requirement already satisfied: pyyaml>=5.1 in /home/user/.local/lib/python3.8/site-packages (from fvcore<0.1.6,>=0.1.5->detectron2) (5.1)
Requirement already satisfied: numpy in /home/user/.local/lib/python3.8/site-packages (from fvcore<0.1.6,>=0.1.5->detectron2) (1.23.4)
Requirement already satisfied: antlr4-python3-runtime==4.9.* in /home/user/.local/lib/python3.8/site-packages (from hydra-core>=1.1->detectron2) (4.9.3)
Requirement already satisfied: packaging in /home/user/.local/lib/python3.8/site-packages (from hydra-core>=1.1->detectron2) (21.3)
Requirement already satisfied: importlib-resources in /home/user/.local/lib/python3.8/site-packages (from hydra-core>=1.1->detectron2) (5.10.0)
Requirement already satisfied: portalocker in /home/user/.local/lib/python3.8/site-packages (from iopath<0.1.10,>=0.1.7->detectron2) (2.6.0)
Requirement already satisfied: cycler>=0.10 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->detectron2) (0.11.0)
Requirement already satisfied: kiwisolver>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->detectron2) (1.4.4)
Requirement already satisfied: contourpy>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->detectron2) (1.0.5)
Requirement already satisfied: python-dateutil>=2.7 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->detectron2) (2.8.2)
Requirement already satisfied: pyparsing>=2.2.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->detectron2) (3.0.9)
Requirement already satisfied: fonttools>=4.22.0 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->detectron2) (4.38.0)
Collecting google-auth<3,>=1.6.3
  Downloading google_auth-2.13.0-py2.py3-none-any.whl (174 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 174.5/174.5 KB 34.3 MB/s eta 0:00:00
Collecting absl-py>=0.4
  Downloading absl_py-1.3.0-py3-none-any.whl (124 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 124.6/124.6 KB 33.4 MB/s eta 0:00:00
Collecting tensorboard-plugin-wit>=1.6.0
  Downloading tensorboard_plugin_wit-1.8.1-py3-none-any.whl (781 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 781.3/781.3 KB 79.8 MB/s eta 0:00:00
Collecting markdown>=2.6.8
  Downloading Markdown-3.4.1-py3-none-any.whl (93 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 93.3/93.3 KB 20.0 MB/s eta 0:00:00
Requirement already satisfied: setuptools>=41.0.0 in /usr/local/lib/python3.8/site-packages (from tensorboard->detectron2) (56.0.0)
Requirement already satisfied: requests<3,>=2.21.0 in /home/user/.local/lib/python3.8/site-packages (from tensorboard->detectron2) (2.28.1)
Collecting tensorboard-data-server<0.7.0,>=0.6.0
  Downloading tensorboard_data_server-0.6.1-py3-none-manylinux2010_x86_64.whl (4.9 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 4.9/4.9 MB 122.4 MB/s eta 0:00:00
Collecting google-auth-oauthlib<0.5,>=0.4.1
  Downloading google_auth_oauthlib-0.4.6-py2.py3-none-any.whl (18 kB)
Collecting protobuf<3.20,>=3.9.2
  Downloading protobuf-3.19.6-cp38-cp38-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (1.1 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 1.1/1.1 MB 108.9 MB/s eta 0:00:00
Requirement already satisfied: wheel>=0.26 in /usr/local/lib/python3.8/site-packages (from tensorboard->detectron2) (0.36.2)
Requirement already satisfied: werkzeug>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from tensorboard->detectron2) (2.2.2)
Collecting grpcio>=1.24.3
  Downloading grpcio-1.50.0-cp38-cp38-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (4.7 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 4.7/4.7 MB 131.6 MB/s eta 0:00:00
Collecting pyasn1-modules>=0.2.1
  Downloading pyasn1_modules-0.2.8-py2.py3-none-any.whl (155 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 155.3/155.3 KB 35.0 MB/s eta 0:00:00
Requirement already satisfied: cachetools<6.0,>=2.0.0 in /home/user/.local/lib/python3.8/site-packages (from google-auth<3,>=1.6.3->tensorboard->detectron2) (5.2.0)
Collecting rsa<5,>=3.1.4
  Downloading rsa-4.9-py3-none-any.whl (34 kB)
Requirement already satisfied: six>=1.9.0 in /home/user/.local/lib/python3.8/site-packages (from google-auth<3,>=1.6.3->tensorboard->detectron2) (1.16.0)
Collecting requests-oauthlib>=0.7.0
  Downloading requests_oauthlib-1.3.1-py2.py3-none-any.whl (23 kB)
Requirement already satisfied: importlib-metadata>=4.4 in /home/user/.local/lib/python3.8/site-packages (from markdown>=2.6.8->tensorboard->detectron2) (5.0.0)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in /home/user/.local/lib/python3.8/site-packages (from requests<3,>=2.21.0->tensorboard->detectron2) (1.26.12)
Requirement already satisfied: charset-normalizer<3,>=2 in /home/user/.local/lib/python3.8/site-packages (from requests<3,>=2.21.0->tensorboard->detectron2) (2.1.1)
Requirement already satisfied: certifi>=2017.4.17 in /home/user/.local/lib/python3.8/site-packages (from requests<3,>=2.21.0->tensorboard->detectron2) (2022.9.24)
Requirement already satisfied: idna<4,>=2.5 in /home/user/.local/lib/python3.8/site-packages (from requests<3,>=2.21.0->tensorboard->detectron2) (3.4)
Requirement already satisfied: MarkupSafe>=2.1.1 in /home/user/.local/lib/python3.8/site-packages (from werkzeug>=1.0.1->tensorboard->detectron2) (2.1.1)
Requirement already satisfied: zipp>=3.1.0 in /home/user/.local/lib/python3.8/site-packages (from importlib-resources->hydra-core>=1.1->detectron2) (3.10.0)
Collecting pyasn1<0.5.0,>=0.4.6
  Downloading pyasn1-0.4.8-py2.py3-none-any.whl (77 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 77.1/77.1 KB 21.6 MB/s eta 0:00:00
Collecting oauthlib>=3.0.0
  Downloading oauthlib-3.2.2-py3-none-any.whl (151 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 151.7/151.7 KB 41.4 MB/s eta 0:00:00
Building wheels for collected packages: pycocotools
  Building wheel for pycocotools (pyproject.toml): started
  Building wheel for pycocotools (pyproject.toml): finished with status 'done'
  Created wheel for pycocotools: filename=pycocotools-2.0.5-cp38-cp38-linux_x86_64.whl size=385630 sha256=8e90770f0d233deb7d63ae8755bdfbf3e6c006c5481b5322e009099eb018f01c
  Stored in directory: /home/user/.cache/pip/wheels/88/17/cf/70d56b589c12b80ea6cc98f3aba11eea103993b660198788c0
Successfully built pycocotools
Installing collected packages: tensorboard-plugin-wit, pyasn1, mypy-extensions, appdirs, tensorboard-data-server, rsa, pydot, pyasn1-modules, protobuf, pathspec, oauthlib, iopath, grpcio, absl-py, requests-oauthlib, markdown, google-auth, black, pycocotools, google-auth-oauthlib, tensorboard, detectron2
  Attempting uninstall: protobuf
    Found existing installation: protobuf 3.20.3
    Uninstalling protobuf-3.20.3:
      Successfully uninstalled protobuf-3.20.3
  Attempting uninstall: iopath
    Found existing installation: iopath 0.1.10
    Uninstalling iopath-0.1.10:
      Successfully uninstalled iopath-0.1.10
Successfully installed absl-py-1.3.0 appdirs-1.4.4 black-21.4b2 detectron2-0.6+cu102 google-auth-2.13.0 google-auth-oauthlib-0.4.6 grpcio-1.50.0 iopath-0.1.9 markdown-3.4.1 mypy-extensions-0.4.3 oauthlib-3.2.2 pathspec-0.10.1 protobuf-3.19.6 pyasn1-0.4.8 pyasn1-modules-0.2.8 pycocotools-2.0.5 pydot-1.4.2 requests-oauthlib-1.3.1 rsa-4.9 tensorboard-2.10.1 tensorboard-data-server-0.6.1 tensorboard-plugin-wit-1.8.1
WARNING: You are using pip version 22.0.2; however, version 22.3 is available.
You should consider upgrading via the '/usr/local/bin/python -m pip install --upgrade pip' command.
Cloning into 'Detic'...
Submodule 'third_party/CenterNet2' (https://github.com/xingyizhou/CenterNet2.git) registered for path 'third_party/CenterNet2'
Submodule 'third_party/Deformable-DETR' (https://github.com/fundamentalvision/Deformable-DETR.git) registered for path 'third_party/Deformable-DETR'
Cloning into '/home/user/app/Detic/third_party/CenterNet2'...
Cloning into '/home/user/app/Detic/third_party/Deformable-DETR'...
Submodule path 'third_party/CenterNet2': checked out '8745e012e4dbdf560ac2f27e0b771d4907ad4aaf'
Submodule path 'third_party/Deformable-DETR': checked out '11169a60c33333af00a4849f1808023eba96a931'
Traceback (most recent call last):
  File "app.py", line 36, in <module>
    from centernet.config import add_centernet_config
ModuleNotFoundError: No module named 'centernet'