runtime error

Space not ready. Reason: Error, exitCode: 1, message: None

Container logs:

Defaulting to user installation because normal site-packages is not writeable
Requirement already satisfied: gradio in /home/user/.local/lib/python3.8/site-packages (2.9.0)
Collecting gradio
  Downloading gradio-3.0.10-py3-none-any.whl (5.1 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 5.1/5.1 MB 81.8 MB/s eta 0:00:00
Requirement already satisfied: aiohttp in /home/user/.local/lib/python3.8/site-packages (from gradio) (3.8.1)
Requirement already satisfied: pandas in /home/user/.local/lib/python3.8/site-packages (from gradio) (1.4.2)
Requirement already satisfied: fastapi in /home/user/.local/lib/python3.8/site-packages (from gradio) (0.78.0)
Requirement already satisfied: pycryptodome in /home/user/.local/lib/python3.8/site-packages (from gradio) (3.14.1)
Requirement already satisfied: pillow in /home/user/.local/lib/python3.8/site-packages (from gradio) (9.1.1)
Requirement already satisfied: Jinja2 in /home/user/.local/lib/python3.8/site-packages (from gradio) (3.1.2)
Requirement already satisfied: numpy in /home/user/.local/lib/python3.8/site-packages (from gradio) (1.22.4)
Requirement already satisfied: paramiko in /home/user/.local/lib/python3.8/site-packages (from gradio) (2.11.0)
Requirement already satisfied: orjson in /home/user/.local/lib/python3.8/site-packages (from gradio) (3.6.9)
Requirement already satisfied: pydub in /home/user/.local/lib/python3.8/site-packages (from gradio) (0.25.1)
Requirement already satisfied: requests in /home/user/.local/lib/python3.8/site-packages (from gradio) (2.27.1)
Requirement already satisfied: analytics-python in /home/user/.local/lib/python3.8/site-packages (from gradio) (1.4.0)
Requirement already satisfied: matplotlib in /home/user/.local/lib/python3.8/site-packages (from gradio) (3.1.0)
Requirement already satisfied: python-multipart in /home/user/.local/lib/python3.8/site-packages (from gradio) (0.0.5)
Requirement already satisfied: markdown-it-py[linkify,plugins] in /home/user/.local/lib/python3.8/site-packages (from gradio) (2.1.0)
Requirement already satisfied: uvicorn in /home/user/.local/lib/python3.8/site-packages (from gradio) (0.17.6)
Requirement already satisfied: ffmpy in /home/user/.local/lib/python3.8/site-packages (from gradio) (0.3.0)
Requirement already satisfied: yarl<2.0,>=1.0 in /home/user/.local/lib/python3.8/site-packages (from aiohttp->gradio) (1.7.2)
Requirement already satisfied: frozenlist>=1.1.1 in /home/user/.local/lib/python3.8/site-packages (from aiohttp->gradio) (1.3.0)
Requirement already satisfied: multidict<7.0,>=4.5 in /home/user/.local/lib/python3.8/site-packages (from aiohttp->gradio) (6.0.2)
Requirement already satisfied: async-timeout<5.0,>=4.0.0a3 in /home/user/.local/lib/python3.8/site-packages (from aiohttp->gradio) (4.0.2)
Requirement already satisfied: attrs>=17.3.0 in /home/user/.local/lib/python3.8/site-packages (from aiohttp->gradio) (21.4.0)
Requirement already satisfied: charset-normalizer<3.0,>=2.0 in /home/user/.local/lib/python3.8/site-packages (from aiohttp->gradio) (2.0.12)
Requirement already satisfied: aiosignal>=1.1.2 in /home/user/.local/lib/python3.8/site-packages (from aiohttp->gradio) (1.2.0)
Requirement already satisfied: backoff==1.10.0 in /home/user/.local/lib/python3.8/site-packages (from analytics-python->gradio) (1.10.0)
Requirement already satisfied: monotonic>=1.5 in /home/user/.local/lib/python3.8/site-packages (from analytics-python->gradio) (1.6)
Requirement already satisfied: six>=1.5 in /home/user/.local/lib/python3.8/site-packages (from analytics-python->gradio) (1.16.0)
Requirement already satisfied: python-dateutil>2.1 in /home/user/.local/lib/python3.8/site-packages (from analytics-python->gradio) (2.8.2)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in /home/user/.local/lib/python3.8/site-packages (from requests->gradio) (1.26.9)
Requirement already satisfied: certifi>=2017.4.17 in /home/user/.local/lib/python3.8/site-packages (from requests->gradio) (2022.5.18.1)
Requirement already satisfied: idna<4,>=2.5 in /home/user/.local/lib/python3.8/site-packages (from requests->gradio) (3.3)
Requirement already satisfied: starlette==0.19.1 in /home/user/.local/lib/python3.8/site-packages (from fastapi->gradio) (0.19.1)
Requirement already satisfied: pydantic!=1.7,!=1.7.1,!=1.7.2,!=1.7.3,!=1.8,!=1.8.1,<2.0.0,>=1.6.2 in /home/user/.local/lib/python3.8/site-packages (from fastapi->gradio) (1.9.1)
Requirement already satisfied: typing-extensions>=3.10.0 in /home/user/.local/lib/python3.8/site-packages (from starlette==0.19.1->fastapi->gradio) (4.2.0)
Requirement already satisfied: anyio<5,>=3.4.0 in /home/user/.local/lib/python3.8/site-packages (from starlette==0.19.1->fastapi->gradio) (3.6.1)
Requirement already satisfied: MarkupSafe>=2.0 in /home/user/.local/lib/python3.8/site-packages (from Jinja2->gradio) (2.1.1)
Requirement already satisfied: mdurl~=0.1 in /home/user/.local/lib/python3.8/site-packages (from markdown-it-py[linkify,plugins]->gradio) (0.1.1)
Requirement already satisfied: mdit-py-plugins in /home/user/.local/lib/python3.8/site-packages (from markdown-it-py[linkify,plugins]->gradio) (0.3.0)
Requirement already satisfied: linkify-it-py~=1.0 in /home/user/.local/lib/python3.8/site-packages (from markdown-it-py[linkify,plugins]->gradio) (1.0.3)
Requirement already satisfied: pyparsing!=2.0.4,!=2.1.2,!=2.1.6,>=2.0.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->gradio) (3.0.9)
Requirement already satisfied: kiwisolver>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->gradio) (1.4.2)
Requirement already satisfied: cycler>=0.10 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->gradio) (0.11.0)
Requirement already satisfied: pytz>=2020.1 in /home/user/.local/lib/python3.8/site-packages (from pandas->gradio) (2022.1)
Requirement already satisfied: cryptography>=2.5 in /home/user/.local/lib/python3.8/site-packages (from paramiko->gradio) (37.0.2)
Requirement already satisfied: bcrypt>=3.1.3 in /home/user/.local/lib/python3.8/site-packages (from paramiko->gradio) (3.2.2)
Requirement already satisfied: pynacl>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from paramiko->gradio) (1.5.0)
Requirement already satisfied: click>=7.0 in /home/user/.local/lib/python3.8/site-packages (from uvicorn->gradio) (8.0.4)
Requirement already satisfied: asgiref>=3.4.0 in /home/user/.local/lib/python3.8/site-packages (from uvicorn->gradio) (3.5.2)
Requirement already satisfied: h11>=0.8 in /home/user/.local/lib/python3.8/site-packages (from uvicorn->gradio) (0.13.0)
Requirement already satisfied: cffi>=1.1 in /home/user/.local/lib/python3.8/site-packages (from bcrypt>=3.1.3->paramiko->gradio) (1.15.0)
Requirement already satisfied: uc-micro-py in /home/user/.local/lib/python3.8/site-packages (from linkify-it-py~=1.0->markdown-it-py[linkify,plugins]->gradio) (1.0.1)
Requirement already satisfied: sniffio>=1.1 in /home/user/.local/lib/python3.8/site-packages (from anyio<5,>=3.4.0->starlette==0.19.1->fastapi->gradio) (1.2.0)
Requirement already satisfied: pycparser in /home/user/.local/lib/python3.8/site-packages (from cffi>=1.1->bcrypt>=3.1.3->paramiko->gradio) (2.21)
Installing collected packages: gradio
  Attempting uninstall: gradio
    Found existing installation: gradio 2.9.0
    Uninstalling gradio-2.9.0:
      Successfully uninstalled gradio-2.9.0
Successfully installed gradio-3.0.10
WARNING: You are using pip version 22.0.2; however, version 22.1.2 is available.
You should consider upgrading via the '/usr/local/bin/python -m pip install --upgrade pip' command.
absl-py==1.0.0
aiohttp==3.8.1
aiosignal==1.2.0
altair==4.2.0
analytics-python==1.4.0
anyio==3.6.1
appdirs==1.4.4
argon2-cffi==21.3.0
argon2-cffi-bindings==21.2.0
asgiref==3.5.2
asttokens==2.0.5
async-timeout==4.0.2
attrs==21.4.0
audioread==2.1.9
backcall==0.2.0
backoff==1.10.0
backports.zoneinfo==0.2.1
bcrypt==3.2.2
beautifulsoup4==4.11.1
bleach==5.0.0
blinker==1.4
Bottleneck==1.3.4
cachetools==5.2.0
certifi==2022.5.18.1
cffi==1.15.0
charset-normalizer==2.0.12
ci-sdr==0.0.0
click==8.0.4
ConfigArgParse==1.5.3
cryptography==37.0.2
ctc-segmentation==1.7.1
cycler==0.11.0
Cython==0.29.30
datasets==2.2.2
debugpy==1.6.0
decorator==5.1.1
defusedxml==0.7.1
dill==0.3.4
Distance==0.1.3
docker-pycreds==0.4.0
editdistance==0.5.2
einops==0.4.1
entrypoints==0.4
espnet==0.10.0
espnet-model-zoo==0.1.7
espnet-tts-frontend==0.0.3
executing==0.8.3
fastapi==0.78.0
fastjsonschema==2.15.3
ffmpy==0.3.0
filelock==3.7.1
frozenlist==1.3.0
fsspec==2022.5.0
g2p-en==2.1.0
gitdb==4.0.9
GitPython==3.1.27
google-auth==2.6.6
google-auth-oauthlib==0.4.6
gradio==3.0.10
grpcio==1.46.3
h11==0.13.0
h5py==3.7.0
huggingface-hub==0.7.0
humanfriendly==10.0
idna==3.3
importlib-metadata==4.11.4
importlib-resources==5.7.1
inflect==5.6.0
ipykernel==6.13.0
ipython==8.4.0
ipython-genutils==0.2.0
ipywidgets==7.7.0
jaconv==0.3
jedi==0.18.1
Jinja2==3.1.2
joblib==1.1.0
jsonschema==4.5.1
jupyter-client==7.3.1
jupyter-core==4.10.0
jupyterlab-pygments==0.2.2
jupyterlab-widgets==1.1.0
kaldiio==2.17.2
kiwisolver==1.4.2
librosa==0.9.1
linkify-it-py==1.0.3
llvmlite==0.38.1
Markdown==3.3.7
markdown-it-py==2.1.0
MarkupSafe==2.1.1
matplotlib==3.1.0
matplotlib-inline==0.1.3
mdit-py-plugins==0.3.0
mdurl==0.1.1
mistune==0.8.4
monotonic==1.6
multidict==6.0.2
multiprocess==0.70.12.2
nara-wpe==0.0.8
nbclient==0.6.4
nbconvert==6.5.0
nbformat==5.4.0
nest-asyncio==1.5.5
nltk==3.7
notebook==6.4.11
numba==0.55.2
numpy==1.22.4
oauthlib==3.2.0
orjson==3.6.9
packaging==21.3
pandas==1.4.2
pandocfilters==1.5.0
paramiko==2.11.0
parso==0.8.3
pathtools==0.1.2
pexpect==4.8.0
pickleshare==0.7.5
Pillow==9.1.1
pooch==1.6.0
prometheus-client==0.14.1
promise==2.3
prompt-toolkit==3.0.29
protobuf==3.20.1
psutil==5.9.1
ptyprocess==0.7.0
pure-eval==0.2.2
pyarrow==8.0.0
pyasn1==0.4.8
pyasn1-modules==0.2.8
pycparser==2.21
pycryptodome==3.14.1
pydantic==1.9.1
pydeck==0.7.1
pydub==0.25.1
Pygments==2.12.0
Pympler==1.0.1
PyNaCl==1.5.0
pyparsing==3.0.9
pypinyin==0.46.0
pyrsistent==0.18.1
python-dateutil==2.8.2
python-multipart==0.0.5
pytorch-wpe==0.0.1
pytz==2022.1
pytz-deprecation-shim==0.1.0.post0
pyworld==0.3.0
PyYAML==6.0
pyzmq==23.0.0
regex==2022.4.24
requests==2.27.1
requests-oauthlib==1.3.1
resampy==0.2.2
responses==0.18.0
rsa==4.8
scikit-learn==1.1.1
scipy==1.8.1
semver==2.13.0
Send2Trash==1.8.0
sentencepiece==0.1.86
sentry-sdk==1.5.12
setproctitle==1.2.3
shortuuid==1.0.9
six==1.16.0
smmap==5.0.0
sniffio==1.2.0
SoundFile==0.10.3.post1
soupsieve==2.3.2.post1
stack-data==0.2.0
starlette==0.19.1
streamlit==1.9.0
tensorboard==2.9.0
tensorboard-data-server==0.6.1
tensorboard-plugin-wit==1.8.1
tensorboardX==2.5
terminado==0.15.0
threadpoolctl==3.1.0
tinycss2==1.1.1
toml==0.10.2
toolz==0.11.2
torch==1.11.0
torch-complex==0.4.3
tornado==6.1
tqdm==4.64.0
traitlets==5.2.2.post1
typeguard==2.13.3
typing_extensions==4.2.0
tzdata==2022.1
tzlocal==4.2
uc-micro-py==1.0.1
Unidecode==1.3.4
urllib3==1.26.9
uvicorn==0.17.6
validators==0.19.0
wandb==0.12.17
watchdog==2.1.8
wcwidth==0.2.5
webencodings==0.5.1
Werkzeug==2.1.2
wget==3.2
widgetsnbextension==3.6.0
xxhash==3.0.0
yarl==1.7.2
zipp==3.8.0
[nltk_data] Downloading package averaged_perceptron_tagger to
[nltk_data]     /home/user/nltk_data...
[nltk_data]   Unzipping taggers/averaged_perceptron_tagger.zip.
[nltk_data] Downloading package cmudict to /home/user/nltk_data...
[nltk_data]   Unzipping corpora/cmudict.zip.
/home/user/.local/lib/python3.8/site-packages/gradio/deprecation.py:40: UserWarning: `optional` parameter is deprecated, and it has no effect
  warnings.warn(value)
/home/user/.local/lib/python3.8/site-packages/gradio/deprecation.py:40: UserWarning: The 'type' parameter has been deprecated. Use the Number component instead.
  warnings.warn(value)
/home/user/.local/lib/python3.8/site-packages/gradio/deprecation.py:40: UserWarning: `enable_queue` is deprecated in `Interface()`, please use it within `launch()` instead.
  warnings.warn(value)
/home/user/.local/lib/python3.8/site-packages/gradio/interface.py:286: UserWarning: Currently, only the 'default' theme is supported.
  warnings.warn("Currently, only the 'default' theme is supported.")
Cache at /home/user/app/gradio_cached_examples/log.csv not found. Caching now in 'gradio_cached_examples/' directory.
Traceback (most recent call last):
  File "app.py", line 56, in <module>
    gr.Interface(inference, inputs, outputs, title=title, description=description, article=article,examples=examples, enable_queue=True).launch()
  File "/home/user/.local/lib/python3.8/site-packages/gradio/interface.py", line 420, in __init__
    cache_interface_examples(self)
  File "/home/user/.local/lib/python3.8/site-packages/gradio/process_examples.py", line 51, in cache_interface_examples
    raise e
  File "/home/user/.local/lib/python3.8/site-packages/gradio/process_examples.py", line 47, in cache_interface_examples
    prediction = process_example(interface, example_id)
  File "/home/user/.local/lib/python3.8/site-packages/gradio/process_examples.py", line 29, in process_example
    prediction = interface.process(raw_input)
  File "/home/user/.local/lib/python3.8/site-packages/gradio/interface.py", line 709, in process
    processed_input = [
  File "/home/user/.local/lib/python3.8/site-packages/gradio/interface.py", line 710, in <listcomp>
    input_component.preprocess(raw_input[i])
IndexError: list index out of range