Spaces:
MT3
Runtime error

runtime error

Space not ready. Reason: Error, exitCode: 1, message: None

Container logs:

Defaulting to user installation because normal site-packages is not writeable
Collecting gradio==2.4.6
  Downloading gradio-2.4.6-py3-none-any.whl (979 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 979.1/979.1 KB 66.1 MB/s eta 0:00:00
Requirement already satisfied: requests in /home/user/.local/lib/python3.8/site-packages (from gradio==2.4.6) (2.27.1)
Collecting Flask-Login
  Downloading Flask_Login-0.6.1-py3-none-any.whl (17 kB)
Collecting Flask>=1.1.1
  Downloading Flask-2.1.2-py3-none-any.whl (95 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 95.2/95.2 KB 22.8 MB/s eta 0:00:00
Collecting Flask-Cors>=3.0.8
  Downloading Flask_Cors-3.0.10-py2.py3-none-any.whl (14 kB)
Requirement already satisfied: ffmpy in /home/user/.local/lib/python3.8/site-packages (from gradio==2.4.6) (0.3.0)
Requirement already satisfied: pandas in /home/user/.local/lib/python3.8/site-packages (from gradio==2.4.6) (1.4.2)
Requirement already satisfied: numpy in /home/user/.local/lib/python3.8/site-packages (from gradio==2.4.6) (1.22.4)
Requirement already satisfied: pycryptodome in /home/user/.local/lib/python3.8/site-packages (from gradio==2.4.6) (3.14.1)
Requirement already satisfied: matplotlib in /home/user/.local/lib/python3.8/site-packages (from gradio==2.4.6) (3.5.2)
Requirement already satisfied: analytics-python in /home/user/.local/lib/python3.8/site-packages (from gradio==2.4.6) (1.4.0)
Requirement already satisfied: pydub in /home/user/.local/lib/python3.8/site-packages (from gradio==2.4.6) (0.25.1)
Collecting markdown2
  Downloading markdown2-2.4.3-py2.py3-none-any.whl (35 kB)
Requirement already satisfied: pillow in /home/user/.local/lib/python3.8/site-packages (from gradio==2.4.6) (9.1.1)
Requirement already satisfied: paramiko in /home/user/.local/lib/python3.8/site-packages (from gradio==2.4.6) (2.11.0)
Collecting flask-cachebuster
  Downloading Flask-CacheBuster-1.0.0.tar.gz (3.1 kB)
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: importlib-metadata>=3.6.0 in /home/user/.local/lib/python3.8/site-packages (from Flask>=1.1.1->gradio==2.4.6) (4.11.4)
Requirement already satisfied: Jinja2>=3.0 in /home/user/.local/lib/python3.8/site-packages (from Flask>=1.1.1->gradio==2.4.6) (3.1.2)
Collecting itsdangerous>=2.0
  Downloading itsdangerous-2.1.2-py3-none-any.whl (15 kB)
Requirement already satisfied: Werkzeug>=2.0 in /home/user/.local/lib/python3.8/site-packages (from Flask>=1.1.1->gradio==2.4.6) (2.1.2)
Requirement already satisfied: click>=8.0 in /home/user/.local/lib/python3.8/site-packages (from Flask>=1.1.1->gradio==2.4.6) (8.0.4)
Requirement already satisfied: Six in /home/user/.local/lib/python3.8/site-packages (from Flask-Cors>=3.0.8->gradio==2.4.6) (1.16.0)
Requirement already satisfied: python-dateutil>2.1 in /home/user/.local/lib/python3.8/site-packages (from analytics-python->gradio==2.4.6) (2.8.2)
Requirement already satisfied: backoff==1.10.0 in /home/user/.local/lib/python3.8/site-packages (from analytics-python->gradio==2.4.6) (1.10.0)
Requirement already satisfied: monotonic>=1.5 in /home/user/.local/lib/python3.8/site-packages (from analytics-python->gradio==2.4.6) (1.6)
Requirement already satisfied: idna<4,>=2.5 in /home/user/.local/lib/python3.8/site-packages (from requests->gradio==2.4.6) (3.3)
Requirement already satisfied: charset-normalizer~=2.0.0 in /home/user/.local/lib/python3.8/site-packages (from requests->gradio==2.4.6) (2.0.12)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in /home/user/.local/lib/python3.8/site-packages (from requests->gradio==2.4.6) (1.26.9)
Requirement already satisfied: certifi>=2017.4.17 in /home/user/.local/lib/python3.8/site-packages (from requests->gradio==2.4.6) (2022.5.18.1)
Requirement already satisfied: kiwisolver>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->gradio==2.4.6) (1.4.2)
Requirement already satisfied: fonttools>=4.22.0 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->gradio==2.4.6) (4.33.3)
Requirement already satisfied: pyparsing>=2.2.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->gradio==2.4.6) (3.0.9)
Requirement already satisfied: packaging>=20.0 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->gradio==2.4.6) (20.9)
Requirement already satisfied: cycler>=0.10 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->gradio==2.4.6) (0.11.0)
Requirement already satisfied: pytz>=2020.1 in /home/user/.local/lib/python3.8/site-packages (from pandas->gradio==2.4.6) (2022.1)
Requirement already satisfied: cryptography>=2.5 in /home/user/.local/lib/python3.8/site-packages (from paramiko->gradio==2.4.6) (37.0.2)
Requirement already satisfied: bcrypt>=3.1.3 in /home/user/.local/lib/python3.8/site-packages (from paramiko->gradio==2.4.6) (3.2.2)
Requirement already satisfied: pynacl>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from paramiko->gradio==2.4.6) (1.5.0)
Requirement already satisfied: cffi>=1.1 in /home/user/.local/lib/python3.8/site-packages (from bcrypt>=3.1.3->paramiko->gradio==2.4.6) (1.15.0)
Requirement already satisfied: zipp>=0.5 in /home/user/.local/lib/python3.8/site-packages (from importlib-metadata>=3.6.0->Flask>=1.1.1->gradio==2.4.6) (3.8.0)
Requirement already satisfied: MarkupSafe>=2.0 in /home/user/.local/lib/python3.8/site-packages (from Jinja2>=3.0->Flask>=1.1.1->gradio==2.4.6) (2.1.1)
Requirement already satisfied: pycparser in /home/user/.local/lib/python3.8/site-packages (from cffi>=1.1->bcrypt>=3.1.3->paramiko->gradio==2.4.6) (2.21)
Building wheels for collected packages: flask-cachebuster
  Building wheel for flask-cachebuster (setup.py): started
  Building wheel for flask-cachebuster (setup.py): finished with status 'done'
  Created wheel for flask-cachebuster: filename=Flask_CacheBuster-1.0.0-py3-none-any.whl size=3372 sha256=a6aa9bfb55bbb0dfaa4f04160616b30fb3524bce7f4e7794cbf5f233fc3c8f31
  Stored in directory: /home/user/.cache/pip/wheels/27/1b/de/34a3e06893944387266e2e7e93d33243589f01ac1b451e367b
Successfully built flask-cachebuster
Installing collected packages: markdown2, itsdangerous, Flask, Flask-Login, Flask-Cors, flask-cachebuster, gradio
  Attempting uninstall: gradio
    Found existing installation: gradio 2.9.0
    Uninstalling gradio-2.9.0:
      Successfully uninstalled gradio-2.9.0
Successfully installed Flask-2.1.2 Flask-Cors-3.0.10 Flask-Login-0.6.1 flask-cachebuster-1.0.0 gradio-2.4.6 itsdangerous-2.1.2 markdown2-2.4.3
WARNING: You are using pip version 22.0.2; however, version 22.1.2 is available.
You should consider upgrading via the '/usr/local/bin/python -m pip install --upgrade pip' command.
Defaulting to user installation because normal site-packages is not writeable
Collecting gsutil
  Downloading gsutil-5.10.tar.gz (2.9 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 2.9/2.9 MB 75.9 MB/s eta 0:00:00
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Collecting argcomplete>=1.9.4
  Downloading argcomplete-2.0.0-py2.py3-none-any.whl (37 kB)
Collecting crcmod>=1.7
  Downloading crcmod-1.7.tar.gz (89 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 89.7/89.7 KB 21.3 MB/s eta 0:00:00
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Collecting fasteners>=0.14.1
  Downloading fasteners-0.17.3-py3-none-any.whl (18 kB)
Collecting gcs-oauth2-boto-plugin>=3.0
  Downloading gcs-oauth2-boto-plugin-3.0.tar.gz (20 kB)
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Collecting google-apitools>=0.5.32
  Downloading google_apitools-0.5.32-py3-none-any.whl (135 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 135.7/135.7 KB 31.9 MB/s eta 0:00:00
Collecting httplib2>=0.20.4
  Downloading httplib2-0.20.4-py3-none-any.whl (96 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 96.6/96.6 KB 30.3 MB/s eta 0:00:00
Collecting google-reauth>=0.1.0
  Downloading google_reauth-0.1.1-py2.py3-none-any.whl (17 kB)
Requirement already satisfied: monotonic>=1.4 in /home/user/.local/lib/python3.8/site-packages (from gsutil) (1.6)
Collecting pyOpenSSL>=0.13
  Downloading pyOpenSSL-22.0.0-py2.py3-none-any.whl (55 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 55.8/55.8 KB 18.0 MB/s eta 0:00:00
Collecting retry_decorator>=1.0.0
  Downloading retry_decorator-1.1.1.tar.gz (3.9 kB)
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: six>=1.12.0 in /home/user/.local/lib/python3.8/site-packages (from gsutil) (1.16.0)
Requirement already satisfied: google-auth[aiohttp]>=2.5.0 in /home/user/.local/lib/python3.8/site-packages (from gsutil) (2.6.6)
Collecting rsa==4.7.2
  Downloading rsa-4.7.2-py3-none-any.whl (34 kB)
Collecting boto>=2.29.1
  Downloading boto-2.49.0-py2.py3-none-any.whl (1.4 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 1.4/1.4 MB 114.5 MB/s eta 0:00:00
Collecting oauth2client>=2.2.0
  Downloading oauth2client-4.1.3-py2.py3-none-any.whl (98 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 98.2/98.2 KB 28.6 MB/s eta 0:00:00
Requirement already satisfied: pyasn1>=0.1.3 in /home/user/.local/lib/python3.8/site-packages (from rsa==4.7.2->gcs-oauth2-boto-plugin>=3.0->gsutil) (0.4.8)
Requirement already satisfied: pyasn1-modules>=0.2.1 in /home/user/.local/lib/python3.8/site-packages (from google-auth[aiohttp]>=2.5.0->gsutil) (0.2.8)
Requirement already satisfied: cachetools<6.0,>=2.0.0 in /home/user/.local/lib/python3.8/site-packages (from google-auth[aiohttp]>=2.5.0->gsutil) (5.2.0)
Requirement already satisfied: requests<3.0.0dev,>=2.20.0 in /home/user/.local/lib/python3.8/site-packages (from google-auth[aiohttp]>=2.5.0->gsutil) (2.27.1)
Requirement already satisfied: aiohttp<4.0.0dev,>=3.6.2 in /home/user/.local/lib/python3.8/site-packages (from google-auth[aiohttp]>=2.5.0->gsutil) (3.8.1)
Collecting pyu2f
  Downloading pyu2f-0.1.5.tar.gz (27 kB)
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: pyparsing!=3.0.0,!=3.0.1,!=3.0.2,!=3.0.3,<4,>=2.4.2 in /home/user/.local/lib/python3.8/site-packages (from httplib2>=0.20.4->gsutil) (3.0.9)
Requirement already satisfied: cryptography>=35.0 in /home/user/.local/lib/python3.8/site-packages (from pyOpenSSL>=0.13->gsutil) (37.0.2)
Requirement already satisfied: attrs>=17.3.0 in /home/user/.local/lib/python3.8/site-packages (from aiohttp<4.0.0dev,>=3.6.2->google-auth[aiohttp]>=2.5.0->gsutil) (21.4.0)
Requirement already satisfied: charset-normalizer<3.0,>=2.0 in /home/user/.local/lib/python3.8/site-packages (from aiohttp<4.0.0dev,>=3.6.2->google-auth[aiohttp]>=2.5.0->gsutil) (2.0.12)
Requirement already satisfied: yarl<2.0,>=1.0 in /home/user/.local/lib/python3.8/site-packages (from aiohttp<4.0.0dev,>=3.6.2->google-auth[aiohttp]>=2.5.0->gsutil) (1.7.2)
Requirement already satisfied: aiosignal>=1.1.2 in /home/user/.local/lib/python3.8/site-packages (from aiohttp<4.0.0dev,>=3.6.2->google-auth[aiohttp]>=2.5.0->gsutil) (1.2.0)
Requirement already satisfied: frozenlist>=1.1.1 in /home/user/.local/lib/python3.8/site-packages (from aiohttp<4.0.0dev,>=3.6.2->google-auth[aiohttp]>=2.5.0->gsutil) (1.3.0)
Requirement already satisfied: multidict<7.0,>=4.5 in /home/user/.local/lib/python3.8/site-packages (from aiohttp<4.0.0dev,>=3.6.2->google-auth[aiohttp]>=2.5.0->gsutil) (6.0.2)
Requirement already satisfied: async-timeout<5.0,>=4.0.0a3 in /home/user/.local/lib/python3.8/site-packages (from aiohttp<4.0.0dev,>=3.6.2->google-auth[aiohttp]>=2.5.0->gsutil) (4.0.2)
Requirement already satisfied: cffi>=1.12 in /home/user/.local/lib/python3.8/site-packages (from cryptography>=35.0->pyOpenSSL>=0.13->gsutil) (1.15.0)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in /home/user/.local/lib/python3.8/site-packages (from requests<3.0.0dev,>=2.20.0->google-auth[aiohttp]>=2.5.0->gsutil) (1.26.9)
Requirement already satisfied: certifi>=2017.4.17 in /home/user/.local/lib/python3.8/site-packages (from requests<3.0.0dev,>=2.20.0->google-auth[aiohttp]>=2.5.0->gsutil) (2022.5.18.1)
Requirement already satisfied: idna<4,>=2.5 in /home/user/.local/lib/python3.8/site-packages (from requests<3.0.0dev,>=2.20.0->google-auth[aiohttp]>=2.5.0->gsutil) (3.3)
Requirement already satisfied: pycparser in /home/user/.local/lib/python3.8/site-packages (from cffi>=1.12->cryptography>=35.0->pyOpenSSL>=0.13->gsutil) (2.21)
Building wheels for collected packages: gsutil, crcmod, gcs-oauth2-boto-plugin, retry_decorator, pyu2f
  Building wheel for gsutil (setup.py): started
  Building wheel for gsutil (setup.py): finished with status 'done'
  Created wheel for gsutil: filename=gsutil-5.10-py3-none-any.whl size=3746885 sha256=fedef24b72cd8040f3d1c01ce5a41215521d127edcdffa1477e33b70b14ebb31
  Stored in directory: /home/user/.cache/pip/wheels/64/c0/67/0b0488d71ea7e91881e9e5a9b2029a1f7c482c13f01f8aeee2
  Building wheel for crcmod (setup.py): started
  Building wheel for crcmod (setup.py): finished with status 'done'
  Created wheel for crcmod: filename=crcmod-1.7-cp38-cp38-linux_x86_64.whl size=35855 sha256=b3a7fb1ccf17387d336b54cfde1394c09ea052b1b22cf04dc32fda0514f55bfa
  Stored in directory: /home/user/.cache/pip/wheels/ca/5a/02/f3acf982a026f3319fb3e798a8dca2d48fafee7761788562e9
  Building wheel for gcs-oauth2-boto-plugin (setup.py): started
  Building wheel for gcs-oauth2-boto-plugin (setup.py): finished with status 'done'
  Created wheel for gcs-oauth2-boto-plugin: filename=gcs_oauth2_boto_plugin-3.0-py3-none-any.whl size=23204 sha256=69cdac1db9bea1c1ab1cffeff1014de3152f7d570c8f6d921c028a60c64a0743
  Stored in directory: /home/user/.cache/pip/wheels/c2/ff/00/10b85e9e1b43efc461153dca75aa47e4640ef41d291b3666a1
  Building wheel for retry_decorator (setup.py): started
  Building wheel for retry_decorator (setup.py): finished with status 'done'
  Created wheel for retry_decorator: filename=retry_decorator-1.1.1-py2.py3-none-any.whl size=3642 sha256=ef3c2557091cf2fff9cf816163c1fa53f66afdbc6020729380b22ffc23a9a060
  Stored in directory: /home/user/.cache/pip/wheels/1e/bb/cb/5d7a05561d7ec60b8c0dc65f156a33909a3eb5c56340959fa9
  Building wheel for pyu2f (setup.py): started
  Building wheel for pyu2f (setup.py): finished with status 'done'
  Created wheel for pyu2f: filename=pyu2f-0.1.5-py3-none-any.whl size=39387 sha256=076532b58ee276f4f321db0e95fd6cb959254d1b0284759c9a494f7c22c723c6
  Stored in directory: /home/user/.cache/pip/wheels/8d/38/8f/378b4491d760a176f261d56310fcb051e53090a894534acbf0
Successfully built gsutil crcmod gcs-oauth2-boto-plugin retry_decorator pyu2f
Installing collected packages: retry_decorator, crcmod, boto, rsa, pyu2f, httplib2, fasteners, argcomplete, oauth2client, google-reauth, pyOpenSSL, google-apitools, gcs-oauth2-boto-plugin, gsutil
  Attempting uninstall: rsa
    Found existing installation: rsa 4.8
    Uninstalling rsa-4.8:
      Successfully uninstalled rsa-4.8
Successfully installed argcomplete-2.0.0 boto-2.49.0 crcmod-1.7 fasteners-0.17.3 gcs-oauth2-boto-plugin-3.0 google-apitools-0.5.32 google-reauth-0.1.1 gsutil-5.10 httplib2-0.20.4 oauth2client-4.1.3 pyOpenSSL-22.0.0 pyu2f-0.1.5 retry_decorator-1.1.1 rsa-4.7.2
WARNING: You are using pip version 22.0.2; however, version 22.1.2 is available.
You should consider upgrading via the '/usr/local/bin/python -m pip install --upgrade pip' command.
Cloning into 't5x'...
Defaulting to user installation because normal site-packages is not writeable
Obtaining file:///home/user/app
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Collecting clu@ git+https://github.com/google/CommonLoopUtils#egg=clu
  Cloning https://github.com/google/CommonLoopUtils to /tmp/pip-install-by31_eeu/clu_1913e217cdac4f489e22a5a78edbccec
  Running command git clone --filter=blob:none --quiet https://github.com/google/CommonLoopUtils /tmp/pip-install-by31_eeu/clu_1913e217cdac4f489e22a5a78edbccec
  Resolved https://github.com/google/CommonLoopUtils to commit 3147a2b5319b1a692b711530a97637d3983f2da5
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Collecting flax@ git+https://github.com/google/flax#egg=flax
  Cloning https://github.com/google/flax to /tmp/pip-install-by31_eeu/flax_0f78d9f234664d989ad080146ef8620c
  Running command git clone --filter=blob:none --quiet https://github.com/google/flax /tmp/pip-install-by31_eeu/flax_0f78d9f234664d989ad080146ef8620c
  Resolved https://github.com/google/flax to commit 9d4505b7df0f8dd756e55bd89a97b793bb2cf914
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: absl-py in /home/user/.local/lib/python3.8/site-packages (from t5x==0.0.0) (1.0.0)
Collecting cached_property
  Downloading cached_property-1.5.2-py2.py3-none-any.whl (7.6 kB)
Requirement already satisfied: gin-config in /home/user/.local/lib/python3.8/site-packages (from t5x==0.0.0) (0.5.0)
Requirement already satisfied: jax>=0.2.27 in /home/user/.local/lib/python3.8/site-packages (from t5x==0.0.0) (0.3.13)
Requirement already satisfied: jaxlib>=0.1.76 in /home/user/.local/lib/python3.8/site-packages (from t5x==0.0.0) (0.3.10)
Requirement already satisfied: numpy in /home/user/.local/lib/python3.8/site-packages (from t5x==0.0.0) (1.22.4)
Collecting orbax
  Downloading orbax-0.0.1-py3-none-any.whl (34 kB)
Collecting seqio-nightly
  Downloading seqio_nightly-0.0.7.dev20220601-py3-none-any.whl (303 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 303.4/303.4 KB 29.5 MB/s eta 0:00:00
Requirement already satisfied: t5 in /home/user/.local/lib/python3.8/site-packages (from t5x==0.0.0) (0.9.3)
Requirement already satisfied: tensorflow in /home/user/.local/lib/python3.8/site-packages (from t5x==0.0.0) (2.9.1)
Collecting tensorstore>=0.1.20
  Downloading tensorstore-0.1.20-cp38-cp38-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (9.0 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 9.0/9.0 MB 131.9 MB/s eta 0:00:00
Requirement already satisfied: typing-extensions in /home/user/.local/lib/python3.8/site-packages (from jax>=0.2.27->t5x==0.0.0) (4.2.0)
Requirement already satisfied: opt-einsum in /home/user/.local/lib/python3.8/site-packages (from jax>=0.2.27->t5x==0.0.0) (3.3.0)
Requirement already satisfied: scipy>=1.2.1 in /home/user/.local/lib/python3.8/site-packages (from jax>=0.2.27->t5x==0.0.0) (1.8.1)
Requirement already satisfied: flatbuffers<3.0,>=1.12 in /home/user/.local/lib/python3.8/site-packages (from jaxlib>=0.1.76->t5x==0.0.0) (1.12)
Requirement already satisfied: six in /home/user/.local/lib/python3.8/site-packages (from absl-py->t5x==0.0.0) (1.16.0)
Requirement already satisfied: etils[epath] in /home/user/.local/lib/python3.8/site-packages (from clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (0.6.0)
Collecting ml_collections
  Downloading ml_collections-0.1.1.tar.gz (77 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 77.9/77.9 KB 24.9 MB/s eta 0:00:00
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: packaging in /home/user/.local/lib/python3.8/site-packages (from clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (20.9)
Requirement already satisfied: tensorflow_datasets in /home/user/.local/lib/python3.8/site-packages (from clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (4.5.2)
Requirement already satisfied: matplotlib in /home/user/.local/lib/python3.8/site-packages (from flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (3.5.2)
Requirement already satisfied: msgpack in /home/user/.local/lib/python3.8/site-packages (from flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (1.0.3)
Requirement already satisfied: optax in /home/user/.local/lib/python3.8/site-packages (from flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (0.1.2)
Collecting rich~=11.1.0
  Downloading rich-11.1.0-py3-none-any.whl (216 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 216.5/216.5 KB 49.5 MB/s eta 0:00:00
Collecting dataclasses
  Downloading dataclasses-0.6-py3-none-any.whl (14 kB)
Requirement already satisfied: sentencepiece in /home/user/.local/lib/python3.8/site-packages (from seqio-nightly->t5x==0.0.0) (0.1.96)
Requirement already satisfied: tensorflow-text in /home/user/.local/lib/python3.8/site-packages (from seqio-nightly->t5x==0.0.0) (2.9.0)
Requirement already satisfied: tfds-nightly in /home/user/.local/lib/python3.8/site-packages (from seqio-nightly->t5x==0.0.0) (4.5.2.dev202206010819)
Requirement already satisfied: rouge-score in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (0.0.4)
Requirement already satisfied: babel in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (2.10.1)
Requirement already satisfied: transformers>=2.7.0 in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (4.19.2)
Requirement already satisfied: mesh-tensorflow[transformer]>=0.1.13 in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (0.1.21)
Requirement already satisfied: seqio in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (0.0.7)
Requirement already satisfied: sacrebleu in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (2.1.0)
Requirement already satisfied: nltk in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (3.7)
Requirement already satisfied: editdistance in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (0.6.0)
Requirement already satisfied: scikit-learn in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (1.1.1)
Requirement already satisfied: torch in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (1.11.0)
Requirement already satisfied: pandas in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (1.4.2)
Requirement already satisfied: grpcio<2.0,>=1.24.3 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->t5x==0.0.0) (1.46.3)
Requirement already satisfied: gast<=0.4.0,>=0.2.1 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->t5x==0.0.0) (0.4.0)
Requirement already satisfied: google-pasta>=0.1.1 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->t5x==0.0.0) (0.2.0)
Requirement already satisfied: termcolor>=1.1.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->t5x==0.0.0) (1.1.0)
Requirement already satisfied: tensorboard<2.10,>=2.9 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->t5x==0.0.0) (2.9.0)
Requirement already satisfied: tensorflow-estimator<2.10.0,>=2.9.0rc0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->t5x==0.0.0) (2.9.0)
Requirement already satisfied: libclang>=13.0.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->t5x==0.0.0) (14.0.1)
Requirement already satisfied: tensorflow-io-gcs-filesystem>=0.23.1 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->t5x==0.0.0) (0.26.0)
Requirement already satisfied: keras<2.10.0,>=2.9.0rc0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->t5x==0.0.0) (2.9.0)
Requirement already satisfied: astunparse>=1.6.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->t5x==0.0.0) (1.6.3)
Requirement already satisfied: setuptools in /usr/local/lib/python3.8/site-packages (from tensorflow->t5x==0.0.0) (56.0.0)
Requirement already satisfied: keras-preprocessing>=1.1.1 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->t5x==0.0.0) (1.1.2)
Requirement already satisfied: protobuf<3.20,>=3.9.2 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->t5x==0.0.0) (3.19.4)
Requirement already satisfied: wrapt>=1.11.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->t5x==0.0.0) (1.14.1)
Requirement already satisfied: h5py>=2.9.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->t5x==0.0.0) (3.7.0)
Requirement already satisfied: wheel<1.0,>=0.23.0 in /usr/local/lib/python3.8/site-packages (from astunparse>=1.6.0->tensorflow->t5x==0.0.0) (0.36.2)
Requirement already satisfied: future in /home/user/.local/lib/python3.8/site-packages (from mesh-tensorflow[transformer]>=0.1.13->t5->t5x==0.0.0) (0.18.2)
Requirement already satisfied: colorama<0.5.0,>=0.4.0 in /home/user/.local/lib/python3.8/site-packages (from rich~=11.1.0->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (0.4.4)
Collecting commonmark<0.10.0,>=0.9.0
  Downloading commonmark-0.9.1-py2.py3-none-any.whl (51 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 51.1/51.1 KB 14.2 MB/s eta 0:00:00
Requirement already satisfied: pygments<3.0.0,>=2.6.0 in /home/user/.local/lib/python3.8/site-packages (from rich~=11.1.0->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (2.12.0)
Requirement already satisfied: markdown>=2.6.8 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.10,>=2.9->tensorflow->t5x==0.0.0) (3.3.7)
Requirement already satisfied: google-auth<3,>=1.6.3 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.10,>=2.9->tensorflow->t5x==0.0.0) (2.6.6)
Requirement already satisfied: werkzeug>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.10,>=2.9->tensorflow->t5x==0.0.0) (2.1.2)
Requirement already satisfied: google-auth-oauthlib<0.5,>=0.4.1 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.10,>=2.9->tensorflow->t5x==0.0.0) (0.4.6)
Requirement already satisfied: tensorboard-plugin-wit>=1.6.0 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.10,>=2.9->tensorflow->t5x==0.0.0) (1.8.1)
Requirement already satisfied: requests<3,>=2.21.0 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.10,>=2.9->tensorflow->t5x==0.0.0) (2.27.1)
Requirement already satisfied: tensorboard-data-server<0.7.0,>=0.6.0 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.10,>=2.9->tensorflow->t5x==0.0.0) (0.6.1)
Requirement already satisfied: regex!=2019.12.17 in /home/user/.local/lib/python3.8/site-packages (from transformers>=2.7.0->t5->t5x==0.0.0) (2022.4.24)
Requirement already satisfied: tokenizers!=0.11.3,<0.13,>=0.11.1 in /home/user/.local/lib/python3.8/site-packages (from transformers>=2.7.0->t5->t5x==0.0.0) (0.12.1)
Requirement already satisfied: tqdm>=4.27 in /home/user/.local/lib/python3.8/site-packages (from transformers>=2.7.0->t5->t5x==0.0.0) (4.64.0)
Requirement already satisfied: filelock in /home/user/.local/lib/python3.8/site-packages (from transformers>=2.7.0->t5->t5x==0.0.0) (3.7.1)
Requirement already satisfied: pyyaml>=5.1 in /home/user/.local/lib/python3.8/site-packages (from transformers>=2.7.0->t5->t5x==0.0.0) (6.0)
Requirement already satisfied: huggingface-hub<1.0,>=0.1.0 in /home/user/.local/lib/python3.8/site-packages (from transformers>=2.7.0->t5->t5x==0.0.0) (0.7.0)
Requirement already satisfied: pyparsing>=2.0.2 in /home/user/.local/lib/python3.8/site-packages (from packaging->clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (3.0.9)
Requirement already satisfied: pytz>=2015.7 in /home/user/.local/lib/python3.8/site-packages (from babel->t5->t5x==0.0.0) (2022.1)
Requirement already satisfied: importlib_resources in /home/user/.local/lib/python3.8/site-packages (from etils[epath]->clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (5.7.1)
Requirement already satisfied: zipp in /home/user/.local/lib/python3.8/site-packages (from etils[epath]->clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (3.8.0)
Requirement already satisfied: cycler>=0.10 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (0.11.0)
Requirement already satisfied: kiwisolver>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (1.4.2)
Requirement already satisfied: pillow>=6.2.0 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (9.1.1)
Requirement already satisfied: python-dateutil>=2.7 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (2.8.2)
Requirement already satisfied: fonttools>=4.22.0 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (4.33.3)
Collecting contextlib2
  Downloading contextlib2-21.6.0-py2.py3-none-any.whl (13 kB)
Requirement already satisfied: click in /home/user/.local/lib/python3.8/site-packages (from nltk->t5->t5x==0.0.0) (8.0.4)
Requirement already satisfied: joblib in /home/user/.local/lib/python3.8/site-packages (from nltk->t5->t5x==0.0.0) (1.1.0)
Requirement already satisfied: chex>=0.0.4 in /home/user/.local/lib/python3.8/site-packages (from optax->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (0.1.3)
Requirement already satisfied: tabulate>=0.8.9 in /home/user/.local/lib/python3.8/site-packages (from sacrebleu->t5->t5x==0.0.0) (0.8.9)
Requirement already satisfied: portalocker in /home/user/.local/lib/python3.8/site-packages (from sacrebleu->t5->t5x==0.0.0) (2.4.0)
Requirement already satisfied: threadpoolctl>=2.0.0 in /home/user/.local/lib/python3.8/site-packages (from scikit-learn->t5->t5x==0.0.0) (3.1.0)
Requirement already satisfied: dill in /home/user/.local/lib/python3.8/site-packages (from tensorflow_datasets->clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (0.3.4)
Requirement already satisfied: tensorflow-metadata in /home/user/.local/lib/python3.8/site-packages (from tensorflow_datasets->clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (1.8.0)
Requirement already satisfied: promise in /home/user/.local/lib/python3.8/site-packages (from tensorflow_datasets->clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (2.3)
Requirement already satisfied: tensorflow-hub>=0.8.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-text->seqio-nightly->t5x==0.0.0) (0.12.0)
Requirement already satisfied: toml in /home/user/.local/lib/python3.8/site-packages (from tfds-nightly->seqio-nightly->t5x==0.0.0) (0.10.2)
Requirement already satisfied: toolz>=0.9.0 in /home/user/.local/lib/python3.8/site-packages (from chex>=0.0.4->optax->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (0.11.2)
Requirement already satisfied: dm-tree>=0.1.5 in /home/user/.local/lib/python3.8/site-packages (from chex>=0.0.4->optax->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (0.1.7)
Requirement already satisfied: cachetools<6.0,>=2.0.0 in /home/user/.local/lib/python3.8/site-packages (from google-auth<3,>=1.6.3->tensorboard<2.10,>=2.9->tensorflow->t5x==0.0.0) (5.2.0)
Requirement already satisfied: rsa<5,>=3.1.4 in /home/user/.local/lib/python3.8/site-packages (from google-auth<3,>=1.6.3->tensorboard<2.10,>=2.9->tensorflow->t5x==0.0.0) (4.7.2)
Requirement already satisfied: pyasn1-modules>=0.2.1 in /home/user/.local/lib/python3.8/site-packages (from google-auth<3,>=1.6.3->tensorboard<2.10,>=2.9->tensorflow->t5x==0.0.0) (0.2.8)
Requirement already satisfied: requests-oauthlib>=0.7.0 in /home/user/.local/lib/python3.8/site-packages (from google-auth-oauthlib<0.5,>=0.4.1->tensorboard<2.10,>=2.9->tensorflow->t5x==0.0.0) (1.3.1)
Requirement already satisfied: importlib-metadata>=4.4 in /home/user/.local/lib/python3.8/site-packages (from markdown>=2.6.8->tensorboard<2.10,>=2.9->tensorflow->t5x==0.0.0) (4.11.4)
Requirement already satisfied: certifi>=2017.4.17 in /home/user/.local/lib/python3.8/site-packages (from requests<3,>=2.21.0->tensorboard<2.10,>=2.9->tensorflow->t5x==0.0.0) (2022.5.18.1)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in /home/user/.local/lib/python3.8/site-packages (from requests<3,>=2.21.0->tensorboard<2.10,>=2.9->tensorflow->t5x==0.0.0) (1.26.9)
Requirement already satisfied: charset-normalizer~=2.0.0 in /home/user/.local/lib/python3.8/site-packages (from requests<3,>=2.21.0->tensorboard<2.10,>=2.9->tensorflow->t5x==0.0.0) (2.0.12)
Requirement already satisfied: idna<4,>=2.5 in /home/user/.local/lib/python3.8/site-packages (from requests<3,>=2.21.0->tensorboard<2.10,>=2.9->tensorflow->t5x==0.0.0) (3.3)
Requirement already satisfied: googleapis-common-protos<2,>=1.52.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-metadata->tensorflow_datasets->clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (1.56.2)
Requirement already satisfied: pyasn1<0.5.0,>=0.4.6 in /home/user/.local/lib/python3.8/site-packages (from pyasn1-modules>=0.2.1->google-auth<3,>=1.6.3->tensorboard<2.10,>=2.9->tensorflow->t5x==0.0.0) (0.4.8)
Requirement already satisfied: oauthlib>=3.0.0 in /home/user/.local/lib/python3.8/site-packages (from requests-oauthlib>=0.7.0->google-auth-oauthlib<0.5,>=0.4.1->tensorboard<2.10,>=2.9->tensorflow->t5x==0.0.0) (3.2.0)
Building wheels for collected packages: clu, ml_collections
  Building wheel for clu (setup.py): started
  Building wheel for clu (setup.py): finished with status 'done'
  Created wheel for clu: filename=clu-0.0.7-py3-none-any.whl size=92734 sha256=fb08288657d4f03ba44b0ffe0b91a5356af6e897e492e6e5fd61533161368d8c
  Stored in directory: /tmp/pip-ephem-wheel-cache-fwcn7w8i/wheels/38/7f/f6/ae0269e264b33e618feb012479e1dcfe10f295085c66fd760e
  Building wheel for ml_collections (setup.py): started
  Building wheel for ml_collections (setup.py): finished with status 'done'
  Created wheel for ml_collections: filename=ml_collections-0.1.1-py3-none-any.whl size=94496 sha256=7d769380c61f73a9266b2591964dcd61e88fbb41bfcf49bafe886f5b148a58c8
  Stored in directory: /home/user/.cache/pip/wheels/6d/9f/a9/9e8309035a5bf09ed9086bbca8c9b74cb6413d3eb203e2bc8c
Successfully built clu ml_collections
Installing collected packages: dataclasses, commonmark, cached_property, tensorstore, rich, contextlib2, ml_collections, orbax, clu, seqio-nightly, t5x
  Running setup.py develop for t5x
Successfully installed cached_property-1.5.2 clu-0.0.7 commonmark-0.9.1 contextlib2-21.6.0 dataclasses-0.6 ml_collections-0.1.1 orbax-0.0.1 rich-11.1.0 seqio-nightly-0.0.7.dev20220601 t5x tensorstore-0.1.20
WARNING: You are using pip version 22.0.2; however, version 22.1.2 is available.
You should consider upgrading via the '/usr/local/bin/python3 -m pip install --upgrade pip' command.
Cloning into 'mt3'...
Defaulting to user installation because normal site-packages is not writeable
Obtaining file:///home/user/app
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: absl-py in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (1.0.0)
Requirement already satisfied: ddsp in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (3.4.4)
Requirement already satisfied: flax in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (0.5.0)
Requirement already satisfied: gin-config in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (0.5.0)
Requirement already satisfied: immutabledict in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (2.2.1)
Requirement already satisfied: librosa in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (0.9.1)
Requirement already satisfied: mir_eval in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (0.7)
Requirement already satisfied: note_seq in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (0.0.3)
Requirement already satisfied: numpy in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (1.22.4)
Requirement already satisfied: pretty_midi in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (0.2.9)
Requirement already satisfied: scikit-learn in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (1.1.1)
Requirement already satisfied: scipy in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (1.8.1)
Requirement already satisfied: seqio in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (0.0.7)
Requirement already satisfied: t5 in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (0.9.3)
Requirement already satisfied: tensorflow in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (2.9.1)
Requirement already satisfied: tensorflow-datasets in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (4.5.2)
Requirement already satisfied: six in /home/user/.local/lib/python3.8/site-packages (from absl-py->mt3==0.0.1) (1.16.0)
Requirement already satisfied: cloudml-hypertune in /home/user/.local/lib/python3.8/site-packages (from ddsp->mt3==0.0.1) (0.1.0.dev6)
Requirement already satisfied: tensorflow-addons in /home/user/.local/lib/python3.8/site-packages (from ddsp->mt3==0.0.1) (0.17.0)
Requirement already satisfied: tensorflow-probability in /home/user/.local/lib/python3.8/site-packages (from ddsp->mt3==0.0.1) (0.16.0)
Requirement already satisfied: crepe>=0.0.11 in /home/user/.local/lib/python3.8/site-packages (from ddsp->mt3==0.0.1) (0.0.12)
Requirement already satisfied: numba<0.50 in /home/user/.local/lib/python3.8/site-packages (from ddsp->mt3==0.0.1) (0.49.1)
Requirement already satisfied: tensorflowjs in /home/user/.local/lib/python3.8/site-packages (from ddsp->mt3==0.0.1) (3.18.0)
Requirement already satisfied: tflite-support in /home/user/.local/lib/python3.8/site-packages (from ddsp->mt3==0.0.1) (0.4.0)
Requirement already satisfied: future in /home/user/.local/lib/python3.8/site-packages (from ddsp->mt3==0.0.1) (0.18.2)
Requirement already satisfied: google-cloud-storage in /home/user/.local/lib/python3.8/site-packages (from ddsp->mt3==0.0.1) (2.3.0)
Requirement already satisfied: pydub in /home/user/.local/lib/python3.8/site-packages (from ddsp->mt3==0.0.1) (0.25.1)
Requirement already satisfied: msgpack in /home/user/.local/lib/python3.8/site-packages (from flax->mt3==0.0.1) (1.0.3)
Requirement already satisfied: optax in /home/user/.local/lib/python3.8/site-packages (from flax->mt3==0.0.1) (0.1.2)
Requirement already satisfied: jax>=0.3 in /home/user/.local/lib/python3.8/site-packages (from flax->mt3==0.0.1) (0.3.13)
Requirement already satisfied: matplotlib in /home/user/.local/lib/python3.8/site-packages (from flax->mt3==0.0.1) (3.5.2)
Requirement already satisfied: typing-extensions>=4.1.1 in /home/user/.local/lib/python3.8/site-packages (from flax->mt3==0.0.1) (4.2.0)
Requirement already satisfied: resampy>=0.2.2 in /home/user/.local/lib/python3.8/site-packages (from librosa->mt3==0.0.1) (0.2.2)
Requirement already satisfied: audioread>=2.1.5 in /home/user/.local/lib/python3.8/site-packages (from librosa->mt3==0.0.1) (2.1.9)
Requirement already satisfied: decorator>=4.0.10 in /home/user/.local/lib/python3.8/site-packages (from librosa->mt3==0.0.1) (5.1.1)
Requirement already satisfied: pooch>=1.0 in /home/user/.local/lib/python3.8/site-packages (from librosa->mt3==0.0.1) (1.6.0)
Requirement already satisfied: joblib>=0.14 in /home/user/.local/lib/python3.8/site-packages (from librosa->mt3==0.0.1) (1.1.0)
Requirement already satisfied: soundfile>=0.10.2 in /home/user/.local/lib/python3.8/site-packages (from librosa->mt3==0.0.1) (0.10.3.post1)
Requirement already satisfied: packaging>=20.0 in /home/user/.local/lib/python3.8/site-packages (from librosa->mt3==0.0.1) (20.9)
Requirement already satisfied: threadpoolctl>=2.0.0 in /home/user/.local/lib/python3.8/site-packages (from scikit-learn->mt3==0.0.1) (3.1.0)
Requirement already satisfied: attrs in /home/user/.local/lib/python3.8/site-packages (from note_seq->mt3==0.0.1) (21.4.0)
Requirement already satisfied: intervaltree>=2.1.0 in /home/user/.local/lib/python3.8/site-packages (from note_seq->mt3==0.0.1) (3.1.0)
Requirement already satisfied: protobuf>=3.6.1 in /home/user/.local/lib/python3.8/site-packages (from note_seq->mt3==0.0.1) (3.19.4)
Requirement already satisfied: bokeh>=0.12.0 in /home/user/.local/lib/python3.8/site-packages (from note_seq->mt3==0.0.1) (2.4.3)
Requirement already satisfied: IPython in /home/user/.local/lib/python3.8/site-packages (from note_seq->mt3==0.0.1) (8.4.0)
Requirement already satisfied: pandas>=0.18.1 in /home/user/.local/lib/python3.8/site-packages (from note_seq->mt3==0.0.1) (1.4.2)
Requirement already satisfied: mido>=1.1.16 in /home/user/.local/lib/python3.8/site-packages (from pretty_midi->mt3==0.0.1) (1.2.10)
Requirement already satisfied: sentencepiece in /home/user/.local/lib/python3.8/site-packages (from seqio->mt3==0.0.1) (0.1.96)
Requirement already satisfied: tfds-nightly in /home/user/.local/lib/python3.8/site-packages (from seqio->mt3==0.0.1) (4.5.2.dev202206010819)
Requirement already satisfied: tensorflow-text in /home/user/.local/lib/python3.8/site-packages (from seqio->mt3==0.0.1) (2.9.0)
Requirement already satisfied: sacrebleu in /home/user/.local/lib/python3.8/site-packages (from t5->mt3==0.0.1) (2.1.0)
Requirement already satisfied: mesh-tensorflow[transformer]>=0.1.13 in /home/user/.local/lib/python3.8/site-packages (from t5->mt3==0.0.1) (0.1.21)
Requirement already satisfied: transformers>=2.7.0 in /home/user/.local/lib/python3.8/site-packages (from t5->mt3==0.0.1) (4.19.2)
Requirement already satisfied: editdistance in /home/user/.local/lib/python3.8/site-packages (from t5->mt3==0.0.1) (0.6.0)
Requirement already satisfied: nltk in /home/user/.local/lib/python3.8/site-packages (from t5->mt3==0.0.1) (3.7)
Requirement already satisfied: rouge-score in /home/user/.local/lib/python3.8/site-packages (from t5->mt3==0.0.1) (0.0.4)
Requirement already satisfied: torch in /home/user/.local/lib/python3.8/site-packages (from t5->mt3==0.0.1) (1.11.0)
Requirement already satisfied: babel in /home/user/.local/lib/python3.8/site-packages (from t5->mt3==0.0.1) (2.10.1)
Requirement already satisfied: setuptools in /usr/local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (56.0.0)
Requirement already satisfied: tensorflow-estimator<2.10.0,>=2.9.0rc0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (2.9.0)
Requirement already satisfied: keras<2.10.0,>=2.9.0rc0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (2.9.0)
Requirement already satisfied: h5py>=2.9.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (3.7.0)
Requirement already satisfied: grpcio<2.0,>=1.24.3 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (1.46.3)
Requirement already satisfied: keras-preprocessing>=1.1.1 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (1.1.2)
Requirement already satisfied: wrapt>=1.11.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (1.14.1)
Requirement already satisfied: termcolor>=1.1.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (1.1.0)
Requirement already satisfied: gast<=0.4.0,>=0.2.1 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (0.4.0)
Requirement already satisfied: astunparse>=1.6.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (1.6.3)
Requirement already satisfied: flatbuffers<2,>=1.12 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (1.12)
Requirement already satisfied: opt-einsum>=2.3.2 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (3.3.0)
Requirement already satisfied: google-pasta>=0.1.1 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (0.2.0)
Requirement already satisfied: libclang>=13.0.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (14.0.1)
Requirement already satisfied: tensorflow-io-gcs-filesystem>=0.23.1 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (0.26.0)
Requirement already satisfied: tensorboard<2.10,>=2.9 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (2.9.0)
Requirement already satisfied: promise in /home/user/.local/lib/python3.8/site-packages (from tensorflow-datasets->mt3==0.0.1) (2.3)
Requirement already satisfied: importlib-resources in /home/user/.local/lib/python3.8/site-packages (from tensorflow-datasets->mt3==0.0.1) (5.7.1)
Requirement already satisfied: tensorflow-metadata in /home/user/.local/lib/python3.8/site-packages (from tensorflow-datasets->mt3==0.0.1) (1.8.0)
Requirement already satisfied: tqdm in /home/user/.local/lib/python3.8/site-packages (from tensorflow-datasets->mt3==0.0.1) (4.64.0)
Requirement already satisfied: dill in /home/user/.local/lib/python3.8/site-packages (from tensorflow-datasets->mt3==0.0.1) (0.3.4)
Requirement already satisfied: requests>=2.19.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-datasets->mt3==0.0.1) (2.27.1)
Requirement already satisfied: wheel<1.0,>=0.23.0 in /usr/local/lib/python3.8/site-packages (from astunparse>=1.6.0->tensorflow->mt3==0.0.1) (0.36.2)
Requirement already satisfied: Jinja2>=2.9 in /home/user/.local/lib/python3.8/site-packages (from bokeh>=0.12.0->note_seq->mt3==0.0.1) (3.1.2)
Requirement already satisfied: tornado>=5.1 in /home/user/.local/lib/python3.8/site-packages (from bokeh>=0.12.0->note_seq->mt3==0.0.1) (6.1)
Requirement already satisfied: PyYAML>=3.10 in /home/user/.local/lib/python3.8/site-packages (from bokeh>=0.12.0->note_seq->mt3==0.0.1) (6.0)
Requirement already satisfied: pillow>=7.1.0 in /home/user/.local/lib/python3.8/site-packages (from bokeh>=0.12.0->note_seq->mt3==0.0.1) (9.1.1)
Requirement already satisfied: imageio>=2.3.0 in /home/user/.local/lib/python3.8/site-packages (from crepe>=0.0.11->ddsp->mt3==0.0.1) (2.19.3)
Requirement already satisfied: hmmlearn<0.3.0,>=0.2.0 in /home/user/.local/lib/python3.8/site-packages (from crepe>=0.0.11->ddsp->mt3==0.0.1) (0.2.7)
Requirement already satisfied: sortedcontainers<3.0,>=2.0 in /home/user/.local/lib/python3.8/site-packages (from intervaltree>=2.1.0->note_seq->mt3==0.0.1) (2.4.0)
Requirement already satisfied: kiwisolver>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax->mt3==0.0.1) (1.4.2)
Requirement already satisfied: cycler>=0.10 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax->mt3==0.0.1) (0.11.0)
Requirement already satisfied: fonttools>=4.22.0 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax->mt3==0.0.1) (4.33.3)
Requirement already satisfied: pyparsing>=2.2.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax->mt3==0.0.1) (3.0.9)
Requirement already satisfied: python-dateutil>=2.7 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax->mt3==0.0.1) (2.8.2)
Requirement already satisfied: llvmlite<=0.33.0.dev0,>=0.31.0.dev0 in /home/user/.local/lib/python3.8/site-packages (from numba<0.50->ddsp->mt3==0.0.1) (0.32.1)
Requirement already satisfied: pytz>=2020.1 in /home/user/.local/lib/python3.8/site-packages (from pandas>=0.18.1->note_seq->mt3==0.0.1) (2022.1)
Requirement already satisfied: appdirs>=1.3.0 in /home/user/.local/lib/python3.8/site-packages (from pooch>=1.0->librosa->mt3==0.0.1) (1.4.4)
Requirement already satisfied: charset-normalizer~=2.0.0 in /home/user/.local/lib/python3.8/site-packages (from requests>=2.19.0->tensorflow-datasets->mt3==0.0.1) (2.0.12)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in /home/user/.local/lib/python3.8/site-packages (from requests>=2.19.0->tensorflow-datasets->mt3==0.0.1) (1.26.9)
Requirement already satisfied: idna<4,>=2.5 in /home/user/.local/lib/python3.8/site-packages (from requests>=2.19.0->tensorflow-datasets->mt3==0.0.1) (3.3)
Requirement already satisfied: certifi>=2017.4.17 in /home/user/.local/lib/python3.8/site-packages (from requests>=2.19.0->tensorflow-datasets->mt3==0.0.1) (2022.5.18.1)
Requirement already satisfied: cffi>=1.0 in /home/user/.local/lib/python3.8/site-packages (from soundfile>=0.10.2->librosa->mt3==0.0.1) (1.15.0)
Requirement already satisfied: werkzeug>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.10,>=2.9->tensorflow->mt3==0.0.1) (2.1.2)
Requirement already satisfied: google-auth<3,>=1.6.3 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.10,>=2.9->tensorflow->mt3==0.0.1) (2.6.6)
Requirement already satisfied: tensorboard-plugin-wit>=1.6.0 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.10,>=2.9->tensorflow->mt3==0.0.1) (1.8.1)
Requirement already satisfied: tensorboard-data-server<0.7.0,>=0.6.0 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.10,>=2.9->tensorflow->mt3==0.0.1) (0.6.1)
Requirement already satisfied: google-auth-oauthlib<0.5,>=0.4.1 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.10,>=2.9->tensorflow->mt3==0.0.1) (0.4.6)
Requirement already satisfied: markdown>=2.6.8 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.10,>=2.9->tensorflow->mt3==0.0.1) (3.3.7)
Requirement already satisfied: huggingface-hub<1.0,>=0.1.0 in /home/user/.local/lib/python3.8/site-packages (from transformers>=2.7.0->t5->mt3==0.0.1) (0.7.0)
Requirement already satisfied: tokenizers!=0.11.3,<0.13,>=0.11.1 in /home/user/.local/lib/python3.8/site-packages (from transformers>=2.7.0->t5->mt3==0.0.1) (0.12.1)
Requirement already satisfied: regex!=2019.12.17 in /home/user/.local/lib/python3.8/site-packages (from transformers>=2.7.0->t5->mt3==0.0.1) (2022.4.24)
Requirement already satisfied: filelock in /home/user/.local/lib/python3.8/site-packages (from transformers>=2.7.0->t5->mt3==0.0.1) (3.7.1)
Requirement already satisfied: google-api-core!=2.0.*,!=2.1.*,!=2.2.*,!=2.3.0,<3.0.0dev,>=1.31.5 in /home/user/.local/lib/python3.8/site-packages (from google-cloud-storage->ddsp->mt3==0.0.1) (2.8.1)
Requirement already satisfied: google-resumable-media>=2.3.2 in /home/user/.local/lib/python3.8/site-packages (from google-cloud-storage->ddsp->mt3==0.0.1) (2.3.3)
Requirement already satisfied: google-cloud-core<3.0dev,>=2.3.0 in /home/user/.local/lib/python3.8/site-packages (from google-cloud-storage->ddsp->mt3==0.0.1) (2.3.0)
Requirement already satisfied: zipp>=3.1.0 in /home/user/.local/lib/python3.8/site-packages (from importlib-resources->tensorflow-datasets->mt3==0.0.1) (3.8.0)
Requirement already satisfied: pygments>=2.4.0 in /home/user/.local/lib/python3.8/site-packages (from IPython->note_seq->mt3==0.0.1) (2.12.0)
Requirement already satisfied: pexpect>4.3 in /home/user/.local/lib/python3.8/site-packages (from IPython->note_seq->mt3==0.0.1) (4.8.0)
Requirement already satisfied: matplotlib-inline in /home/user/.local/lib/python3.8/site-packages (from IPython->note_seq->mt3==0.0.1) (0.1.3)
Requirement already satisfied: stack-data in /home/user/.local/lib/python3.8/site-packages (from IPython->note_seq->mt3==0.0.1) (0.2.0)
Requirement already satisfied: traitlets>=5 in /home/user/.local/lib/python3.8/site-packages (from IPython->note_seq->mt3==0.0.1) (5.2.2.post1)
Requirement already satisfied: backcall in /home/user/.local/lib/python3.8/site-packages (from IPython->note_seq->mt3==0.0.1) (0.2.0)
Requirement already satisfied: jedi>=0.16 in /home/user/.local/lib/python3.8/site-packages (from IPython->note_seq->mt3==0.0.1) (0.18.1)
Requirement already satisfied: prompt-toolkit!=3.0.0,!=3.0.1,<3.1.0,>=2.0.0 in /home/user/.local/lib/python3.8/site-packages (from IPython->note_seq->mt3==0.0.1) (3.0.29)
Requirement already satisfied: pickleshare in /home/user/.local/lib/python3.8/site-packages (from IPython->note_seq->mt3==0.0.1) (0.7.5)
Requirement already satisfied: click in /home/user/.local/lib/python3.8/site-packages (from nltk->t5->mt3==0.0.1) (8.0.4)
Requirement already satisfied: chex>=0.0.4 in /home/user/.local/lib/python3.8/site-packages (from optax->flax->mt3==0.0.1) (0.1.3)
Requirement already satisfied: jaxlib>=0.1.37 in /home/user/.local/lib/python3.8/site-packages (from optax->flax->mt3==0.0.1) (0.3.10)
Requirement already satisfied: colorama in /home/user/.local/lib/python3.8/site-packages (from sacrebleu->t5->mt3==0.0.1) (0.4.4)
Requirement already satisfied: tabulate>=0.8.9 in /home/user/.local/lib/python3.8/site-packages (from sacrebleu->t5->mt3==0.0.1) (0.8.9)
Requirement already satisfied: portalocker in /home/user/.local/lib/python3.8/site-packages (from sacrebleu->t5->mt3==0.0.1) (2.4.0)
Requirement already satisfied: typeguard>=2.7 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-addons->ddsp->mt3==0.0.1) (2.13.3)
Requirement already satisfied: googleapis-common-protos<2,>=1.52.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-metadata->tensorflow-datasets->mt3==0.0.1) (1.56.2)
Requirement already satisfied: dm-tree in /home/user/.local/lib/python3.8/site-packages (from tensorflow-probability->ddsp->mt3==0.0.1) (0.1.7)
Requirement already satisfied: cloudpickle>=1.3 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-probability->ddsp->mt3==0.0.1) (2.1.0)
Requirement already satisfied: tensorflow-hub>=0.8.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-text->seqio->mt3==0.0.1) (0.12.0)
Requirement already satisfied: toml in /home/user/.local/lib/python3.8/site-packages (from tfds-nightly->seqio->mt3==0.0.1) (0.10.2)
Requirement already satisfied: etils[epath-no-tf,epy] in /home/user/.local/lib/python3.8/site-packages (from tfds-nightly->seqio->mt3==0.0.1) (0.6.0)
Requirement already satisfied: sounddevice>=0.4.4 in /home/user/.local/lib/python3.8/site-packages (from tflite-support->ddsp->mt3==0.0.1) (0.4.4)
Requirement already satisfied: pybind11>=2.6.0 in /home/user/.local/lib/python3.8/site-packages (from tflite-support->ddsp->mt3==0.0.1) (2.9.2)
Requirement already satisfied: pycparser in /home/user/.local/lib/python3.8/site-packages (from cffi>=1.0->soundfile>=0.10.2->librosa->mt3==0.0.1) (2.21)
Requirement already satisfied: toolz>=0.9.0 in /home/user/.local/lib/python3.8/site-packages (from chex>=0.0.4->optax->flax->mt3==0.0.1) (0.11.2)
Requirement already satisfied: cachetools<6.0,>=2.0.0 in /home/user/.local/lib/python3.8/site-packages (from google-auth<3,>=1.6.3->tensorboard<2.10,>=2.9->tensorflow->mt3==0.0.1) (5.2.0)
Requirement already satisfied: pyasn1-modules>=0.2.1 in /home/user/.local/lib/python3.8/site-packages (from google-auth<3,>=1.6.3->tensorboard<2.10,>=2.9->tensorflow->mt3==0.0.1) (0.2.8)
Requirement already satisfied: rsa<5,>=3.1.4 in /home/user/.local/lib/python3.8/site-packages (from google-auth<3,>=1.6.3->tensorboard<2.10,>=2.9->tensorflow->mt3==0.0.1) (4.7.2)
Requirement already satisfied: requests-oauthlib>=0.7.0 in /home/user/.local/lib/python3.8/site-packages (from google-auth-oauthlib<0.5,>=0.4.1->tensorboard<2.10,>=2.9->tensorflow->mt3==0.0.1) (1.3.1)
Requirement already satisfied: google-crc32c<2.0dev,>=1.0 in /home/user/.local/lib/python3.8/site-packages (from google-resumable-media>=2.3.2->google-cloud-storage->ddsp->mt3==0.0.1) (1.3.0)
Requirement already satisfied: parso<0.9.0,>=0.8.0 in /home/user/.local/lib/python3.8/site-packages (from jedi>=0.16->IPython->note_seq->mt3==0.0.1) (0.8.3)
Requirement already satisfied: MarkupSafe>=2.0 in /home/user/.local/lib/python3.8/site-packages (from Jinja2>=2.9->bokeh>=0.12.0->note_seq->mt3==0.0.1) (2.1.1)
Requirement already satisfied: importlib-metadata>=4.4 in /home/user/.local/lib/python3.8/site-packages (from markdown>=2.6.8->tensorboard<2.10,>=2.9->tensorflow->mt3==0.0.1) (4.11.4)
Requirement already satisfied: ptyprocess>=0.5 in /home/user/.local/lib/python3.8/site-packages (from pexpect>4.3->IPython->note_seq->mt3==0.0.1) (0.7.0)
Requirement already satisfied: wcwidth in /home/user/.local/lib/python3.8/site-packages (from prompt-toolkit!=3.0.0,!=3.0.1,<3.1.0,>=2.0.0->IPython->note_seq->mt3==0.0.1) (0.2.5)
Requirement already satisfied: executing in /home/user/.local/lib/python3.8/site-packages (from stack-data->IPython->note_seq->mt3==0.0.1) (0.8.3)
Requirement already satisfied: asttokens in /home/user/.local/lib/python3.8/site-packages (from stack-data->IPython->note_seq->mt3==0.0.1) (2.0.5)
Requirement already satisfied: pure-eval in /home/user/.local/lib/python3.8/site-packages (from stack-data->IPython->note_seq->mt3==0.0.1) (0.2.2)
Requirement already satisfied: pyasn1<0.5.0,>=0.4.6 in /home/user/.local/lib/python3.8/site-packages (from pyasn1-modules>=0.2.1->google-auth<3,>=1.6.3->tensorboard<2.10,>=2.9->tensorflow->mt3==0.0.1) (0.4.8)
Requirement already satisfied: oauthlib>=3.0.0 in /home/user/.local/lib/python3.8/site-packages (from requests-oauthlib>=0.7.0->google-auth-oauthlib<0.5,>=0.4.1->tensorboard<2.10,>=2.9->tensorflow->mt3==0.0.1) (3.2.0)
Installing collected packages: mt3
  Running setup.py develop for mt3
Successfully installed mt3
WARNING: You are using pip version 22.0.2; however, version 22.1.2 is available.
You should consider upgrading via the '/usr/local/bin/python3 -m pip install --upgrade pip' command.
2022-06-01 16:18:58.499993: W tensorflow/stream_executor/platform/default/dso_loader.cc:64] Could not load dynamic library 'libcudart.so.11.0'; dlerror: libcudart.so.11.0: cannot open shared object file: No such file or directory
2022-06-01 16:18:58.500033: I tensorflow/stream_executor/cuda/cudart_stub.cc:29] Ignore above cudart dlerror if you do not have a GPU set up on your machine.
Traceback (most recent call last):
  File "app.py", line 263, in <module>
    inference_model = InferenceModel('/home/user/app/checkpoints/mt3/', 'mt3')
  File "app.py", line 88, in __init__
    self.partitioner = t5x.partitioning.ModelBasedPjitPartitioner(
AttributeError: module 't5x.partitioning' has no attribute 'ModelBasedPjitPartitioner'