runtime error

Space not ready. Reason: Error, exitCode: 1, message: None

Container logs:

Defaulting to user installation because normal site-packages is not writeable
Collecting gradio==2.5.3
  Downloading gradio-2.5.3-py3-none-any.whl (985 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 985.1/985.1 KB 48.1 MB/s eta 0:00:00
Requirement already satisfied: analytics-python in /home/user/.local/lib/python3.8/site-packages (from gradio==2.5.3) (1.4.0)
Collecting Flask>=1.1.1
  Downloading Flask-2.2.2-py3-none-any.whl (101 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 101.5/101.5 KB 17.2 MB/s eta 0:00:00
Collecting Flask-Cors>=3.0.8
  Downloading Flask_Cors-3.0.10-py2.py3-none-any.whl (14 kB)
Requirement already satisfied: ffmpy in /home/user/.local/lib/python3.8/site-packages (from gradio==2.5.3) (0.3.0)
Requirement already satisfied: matplotlib in /home/user/.local/lib/python3.8/site-packages (from gradio==2.5.3) (3.6.1)
Requirement already satisfied: pycryptodome in /home/user/.local/lib/python3.8/site-packages (from gradio==2.5.3) (3.15.0)
Collecting flask-cachebuster
  Downloading Flask-CacheBuster-1.0.0.tar.gz (3.1 kB)
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Collecting Flask-Login
  Downloading Flask_Login-0.6.2-py3-none-any.whl (17 kB)
Requirement already satisfied: pydub in /home/user/.local/lib/python3.8/site-packages (from gradio==2.5.3) (0.25.1)
Requirement already satisfied: numpy in /home/user/.local/lib/python3.8/site-packages (from gradio==2.5.3) (1.23.4)
Requirement already satisfied: paramiko in /home/user/.local/lib/python3.8/site-packages (from gradio==2.5.3) (2.11.0)
Requirement already satisfied: requests in /home/user/.local/lib/python3.8/site-packages (from gradio==2.5.3) (2.28.1)
Collecting markdown2
  Downloading markdown2-2.4.6-py2.py3-none-any.whl (37 kB)
Requirement already satisfied: pillow in /home/user/.local/lib/python3.8/site-packages (from gradio==2.5.3) (9.2.0)
Requirement already satisfied: pandas in /home/user/.local/lib/python3.8/site-packages (from gradio==2.5.3) (1.5.1)
Collecting itsdangerous>=2.0
  Downloading itsdangerous-2.1.2-py3-none-any.whl (15 kB)
Requirement already satisfied: importlib-metadata>=3.6.0 in /home/user/.local/lib/python3.8/site-packages (from Flask>=1.1.1->gradio==2.5.3) (5.0.0)
Requirement already satisfied: click>=8.0 in /home/user/.local/lib/python3.8/site-packages (from Flask>=1.1.1->gradio==2.5.3) (8.0.4)
Requirement already satisfied: Werkzeug>=2.2.2 in /home/user/.local/lib/python3.8/site-packages (from Flask>=1.1.1->gradio==2.5.3) (2.2.2)
Requirement already satisfied: Jinja2>=3.0 in /home/user/.local/lib/python3.8/site-packages (from Flask>=1.1.1->gradio==2.5.3) (3.1.2)
Requirement already satisfied: Six in /home/user/.local/lib/python3.8/site-packages (from Flask-Cors>=3.0.8->gradio==2.5.3) (1.16.0)
Requirement already satisfied: python-dateutil>2.1 in /home/user/.local/lib/python3.8/site-packages (from analytics-python->gradio==2.5.3) (2.8.2)
Requirement already satisfied: backoff==1.10.0 in /home/user/.local/lib/python3.8/site-packages (from analytics-python->gradio==2.5.3) (1.10.0)
Requirement already satisfied: monotonic>=1.5 in /home/user/.local/lib/python3.8/site-packages (from analytics-python->gradio==2.5.3) (1.6)
Requirement already satisfied: charset-normalizer<3,>=2 in /home/user/.local/lib/python3.8/site-packages (from requests->gradio==2.5.3) (2.1.1)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in /home/user/.local/lib/python3.8/site-packages (from requests->gradio==2.5.3) (1.26.12)
Requirement already satisfied: idna<4,>=2.5 in /home/user/.local/lib/python3.8/site-packages (from requests->gradio==2.5.3) (3.4)
Requirement already satisfied: certifi>=2017.4.17 in /home/user/.local/lib/python3.8/site-packages (from requests->gradio==2.5.3) (2022.9.24)
Requirement already satisfied: kiwisolver>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->gradio==2.5.3) (1.4.4)
Requirement already satisfied: pyparsing>=2.2.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->gradio==2.5.3) (3.0.9)
Requirement already satisfied: fonttools>=4.22.0 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->gradio==2.5.3) (4.38.0)
Requirement already satisfied: contourpy>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->gradio==2.5.3) (1.0.5)
Requirement already satisfied: packaging>=20.0 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->gradio==2.5.3) (20.9)
Requirement already satisfied: cycler>=0.10 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->gradio==2.5.3) (0.11.0)
Requirement already satisfied: pytz>=2020.1 in /home/user/.local/lib/python3.8/site-packages (from pandas->gradio==2.5.3) (2022.5)
Requirement already satisfied: cryptography>=2.5 in /home/user/.local/lib/python3.8/site-packages (from paramiko->gradio==2.5.3) (38.0.1)
Requirement already satisfied: pynacl>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from paramiko->gradio==2.5.3) (1.5.0)
Requirement already satisfied: bcrypt>=3.1.3 in /home/user/.local/lib/python3.8/site-packages (from paramiko->gradio==2.5.3) (4.0.1)
Requirement already satisfied: cffi>=1.12 in /home/user/.local/lib/python3.8/site-packages (from cryptography>=2.5->paramiko->gradio==2.5.3) (1.15.1)
Requirement already satisfied: zipp>=0.5 in /home/user/.local/lib/python3.8/site-packages (from importlib-metadata>=3.6.0->Flask>=1.1.1->gradio==2.5.3) (3.10.0)
Requirement already satisfied: MarkupSafe>=2.0 in /home/user/.local/lib/python3.8/site-packages (from Jinja2>=3.0->Flask>=1.1.1->gradio==2.5.3) (2.1.1)
Requirement already satisfied: pycparser in /home/user/.local/lib/python3.8/site-packages (from cffi>=1.12->cryptography>=2.5->paramiko->gradio==2.5.3) (2.21)
Building wheels for collected packages: flask-cachebuster
  Building wheel for flask-cachebuster (setup.py): started
  Building wheel for flask-cachebuster (setup.py): finished with status 'done'
  Created wheel for flask-cachebuster: filename=Flask_CacheBuster-1.0.0-py3-none-any.whl size=3372 sha256=84eb612d6e0b16fd82b20d877d320ae1804f9913001941d3e43130df5f0bad39
  Stored in directory: /home/user/.cache/pip/wheels/27/1b/de/34a3e06893944387266e2e7e93d33243589f01ac1b451e367b
Successfully built flask-cachebuster
Installing collected packages: markdown2, itsdangerous, Flask, Flask-Login, Flask-Cors, flask-cachebuster, gradio
  Attempting uninstall: gradio
    Found existing installation: gradio 2.9.0.1
    Uninstalling gradio-2.9.0.1:
      Successfully uninstalled gradio-2.9.0.1
Successfully installed Flask-2.2.2 Flask-Cors-3.0.10 Flask-Login-0.6.2 flask-cachebuster-1.0.0 gradio-2.5.3 itsdangerous-2.1.2 markdown2-2.4.6
WARNING: You are using pip version 22.0.2; however, version 22.3 is available.
You should consider upgrading via the '/usr/local/bin/python -m pip install --upgrade pip' command.
Defaulting to user installation because normal site-packages is not writeable
Collecting gsutil
  Downloading gsutil-5.15.tar.gz (3.0 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 3.0/3.0 MB 62.2 MB/s eta 0:00:00
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Collecting argcomplete>=1.9.4
  Downloading argcomplete-2.0.0-py2.py3-none-any.whl (37 kB)
Collecting crcmod>=1.7
  Downloading crcmod-1.7.tar.gz (89 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 89.7/89.7 KB 2.2 MB/s eta 0:00:00
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Collecting fasteners>=0.14.1
  Downloading fasteners-0.18-py3-none-any.whl (18 kB)
Collecting gcs-oauth2-boto-plugin>=3.0
  Downloading gcs-oauth2-boto-plugin-3.0.tar.gz (20 kB)
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Collecting google-apitools>=0.5.32
  Downloading google_apitools-0.5.32-py3-none-any.whl (135 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 135.7/135.7 KB 7.5 MB/s eta 0:00:00
Collecting httplib2>=0.20.4
  Downloading httplib2-0.20.4-py3-none-any.whl (96 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 96.6/96.6 KB 3.7 MB/s eta 0:00:00
Collecting google-reauth>=0.1.0
  Downloading google_reauth-0.1.1-py2.py3-none-any.whl (17 kB)
Requirement already satisfied: monotonic>=1.4 in /home/user/.local/lib/python3.8/site-packages (from gsutil) (1.6)
Collecting pyOpenSSL>=0.13
  Downloading pyOpenSSL-22.1.0-py3-none-any.whl (57 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 57.0/57.0 KB 3.2 MB/s eta 0:00:00
Collecting retry_decorator>=1.0.0
  Downloading retry_decorator-1.1.1.tar.gz (3.9 kB)
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: six>=1.12.0 in /home/user/.local/lib/python3.8/site-packages (from gsutil) (1.16.0)
Requirement already satisfied: google-auth[aiohttp]>=2.5.0 in /home/user/.local/lib/python3.8/site-packages (from gsutil) (2.13.0)
Collecting rsa==4.7.2
  Downloading rsa-4.7.2-py3-none-any.whl (34 kB)
Collecting boto>=2.29.1
  Downloading boto-2.49.0-py2.py3-none-any.whl (1.4 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 1.4/1.4 MB 65.8 MB/s eta 0:00:00
Collecting oauth2client>=2.2.0
  Downloading oauth2client-4.1.3-py2.py3-none-any.whl (98 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 98.2/98.2 KB 16.2 MB/s eta 0:00:00
Requirement already satisfied: pyasn1>=0.1.3 in /home/user/.local/lib/python3.8/site-packages (from rsa==4.7.2->gcs-oauth2-boto-plugin>=3.0->gsutil) (0.4.8)
Requirement already satisfied: cachetools<6.0,>=2.0.0 in /home/user/.local/lib/python3.8/site-packages (from google-auth[aiohttp]>=2.5.0->gsutil) (5.2.0)
Requirement already satisfied: pyasn1-modules>=0.2.1 in /home/user/.local/lib/python3.8/site-packages (from google-auth[aiohttp]>=2.5.0->gsutil) (0.2.8)
Requirement already satisfied: requests<3.0.0dev,>=2.20.0 in /home/user/.local/lib/python3.8/site-packages (from google-auth[aiohttp]>=2.5.0->gsutil) (2.28.1)
Requirement already satisfied: aiohttp<4.0.0dev,>=3.6.2 in /home/user/.local/lib/python3.8/site-packages (from google-auth[aiohttp]>=2.5.0->gsutil) (3.8.3)
Collecting pyu2f
  Downloading pyu2f-0.1.5.tar.gz (27 kB)
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: pyparsing!=3.0.0,!=3.0.1,!=3.0.2,!=3.0.3,<4,>=2.4.2 in /home/user/.local/lib/python3.8/site-packages (from httplib2>=0.20.4->gsutil) (3.0.9)
Requirement already satisfied: cryptography<39,>=38.0.0 in /home/user/.local/lib/python3.8/site-packages (from pyOpenSSL>=0.13->gsutil) (38.0.1)
Requirement already satisfied: async-timeout<5.0,>=4.0.0a3 in /home/user/.local/lib/python3.8/site-packages (from aiohttp<4.0.0dev,>=3.6.2->google-auth[aiohttp]>=2.5.0->gsutil) (4.0.2)
Requirement already satisfied: multidict<7.0,>=4.5 in /home/user/.local/lib/python3.8/site-packages (from aiohttp<4.0.0dev,>=3.6.2->google-auth[aiohttp]>=2.5.0->gsutil) (6.0.2)
Requirement already satisfied: frozenlist>=1.1.1 in /home/user/.local/lib/python3.8/site-packages (from aiohttp<4.0.0dev,>=3.6.2->google-auth[aiohttp]>=2.5.0->gsutil) (1.3.1)
Requirement already satisfied: aiosignal>=1.1.2 in /home/user/.local/lib/python3.8/site-packages (from aiohttp<4.0.0dev,>=3.6.2->google-auth[aiohttp]>=2.5.0->gsutil) (1.2.0)
Requirement already satisfied: charset-normalizer<3.0,>=2.0 in /home/user/.local/lib/python3.8/site-packages (from aiohttp<4.0.0dev,>=3.6.2->google-auth[aiohttp]>=2.5.0->gsutil) (2.1.1)
Requirement already satisfied: attrs>=17.3.0 in /home/user/.local/lib/python3.8/site-packages (from aiohttp<4.0.0dev,>=3.6.2->google-auth[aiohttp]>=2.5.0->gsutil) (22.1.0)
Requirement already satisfied: yarl<2.0,>=1.0 in /home/user/.local/lib/python3.8/site-packages (from aiohttp<4.0.0dev,>=3.6.2->google-auth[aiohttp]>=2.5.0->gsutil) (1.8.1)
Requirement already satisfied: cffi>=1.12 in /home/user/.local/lib/python3.8/site-packages (from cryptography<39,>=38.0.0->pyOpenSSL>=0.13->gsutil) (1.15.1)
Requirement already satisfied: certifi>=2017.4.17 in /home/user/.local/lib/python3.8/site-packages (from requests<3.0.0dev,>=2.20.0->google-auth[aiohttp]>=2.5.0->gsutil) (2022.9.24)
Requirement already satisfied: idna<4,>=2.5 in /home/user/.local/lib/python3.8/site-packages (from requests<3.0.0dev,>=2.20.0->google-auth[aiohttp]>=2.5.0->gsutil) (3.4)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in /home/user/.local/lib/python3.8/site-packages (from requests<3.0.0dev,>=2.20.0->google-auth[aiohttp]>=2.5.0->gsutil) (1.26.12)
Requirement already satisfied: pycparser in /home/user/.local/lib/python3.8/site-packages (from cffi>=1.12->cryptography<39,>=38.0.0->pyOpenSSL>=0.13->gsutil) (2.21)
Building wheels for collected packages: gsutil, crcmod, gcs-oauth2-boto-plugin, retry_decorator, pyu2f
  Building wheel for gsutil (setup.py): started
  Building wheel for gsutil (setup.py): finished with status 'done'
  Created wheel for gsutil: filename=gsutil-5.15-py3-none-any.whl size=3772054 sha256=0454b46389b7040d00021a5ff6441963402a9d6bce3a3f2a749a4987cadce824
  Stored in directory: /home/user/.cache/pip/wheels/78/a4/95/21b77be81b74d6eeeceaef4cbcc42d43237529cbb11145cd56
  Building wheel for crcmod (setup.py): started
  Building wheel for crcmod (setup.py): finished with status 'done'
  Created wheel for crcmod: filename=crcmod-1.7-cp38-cp38-linux_x86_64.whl size=35854 sha256=65d809d2c3609c182f6867f8d78b7d731e3ebf5cab6926caaad3ba0f196de716
  Stored in directory: /home/user/.cache/pip/wheels/ca/5a/02/f3acf982a026f3319fb3e798a8dca2d48fafee7761788562e9
  Building wheel for gcs-oauth2-boto-plugin (setup.py): started
  Building wheel for gcs-oauth2-boto-plugin (setup.py): finished with status 'done'
  Created wheel for gcs-oauth2-boto-plugin: filename=gcs_oauth2_boto_plugin-3.0-py3-none-any.whl size=23204 sha256=ffa9d9394c51a7fe7b32b1257d2251d6ccee89983c5681663c780f4dc159b5bd
  Stored in directory: /home/user/.cache/pip/wheels/c2/ff/00/10b85e9e1b43efc461153dca75aa47e4640ef41d291b3666a1
  Building wheel for retry_decorator (setup.py): started
  Building wheel for retry_decorator (setup.py): finished with status 'done'
  Created wheel for retry_decorator: filename=retry_decorator-1.1.1-py2.py3-none-any.whl size=3642 sha256=a86ef7c723d844917960958805edda2ada535af2f1a28f78c15eefcfcd73accb
  Stored in directory: /home/user/.cache/pip/wheels/1e/bb/cb/5d7a05561d7ec60b8c0dc65f156a33909a3eb5c56340959fa9
  Building wheel for pyu2f (setup.py): started
  Building wheel for pyu2f (setup.py): finished with status 'done'
  Created wheel for pyu2f: filename=pyu2f-0.1.5-py3-none-any.whl size=39387 sha256=a6eff703cd3e988635e00759e238a26d7535c5568b9fd5a8695ad9102736ac1d
  Stored in directory: /home/user/.cache/pip/wheels/8d/38/8f/378b4491d760a176f261d56310fcb051e53090a894534acbf0
Successfully built gsutil crcmod gcs-oauth2-boto-plugin retry_decorator pyu2f
Installing collected packages: retry_decorator, crcmod, boto, rsa, pyu2f, httplib2, fasteners, argcomplete, oauth2client, google-reauth, pyOpenSSL, google-apitools, gcs-oauth2-boto-plugin, gsutil
  Attempting uninstall: rsa
    Found existing installation: rsa 4.9
    Uninstalling rsa-4.9:
      Successfully uninstalled rsa-4.9
Successfully installed argcomplete-2.0.0 boto-2.49.0 crcmod-1.7 fasteners-0.18 gcs-oauth2-boto-plugin-3.0 google-apitools-0.5.32 google-reauth-0.1.1 gsutil-5.15 httplib2-0.20.4 oauth2client-4.1.3 pyOpenSSL-22.1.0 pyu2f-0.1.5 retry_decorator-1.1.1 rsa-4.7.2
WARNING: You are using pip version 22.0.2; however, version 22.3 is available.
You should consider upgrading via the '/usr/local/bin/python -m pip install --upgrade pip' command.
Cloning into 't5x'...
Defaulting to user installation because normal site-packages is not writeable
Obtaining file:///home/user/app
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Collecting clu@ git+https://github.com/google/CommonLoopUtils#egg=clu
  Cloning https://github.com/google/CommonLoopUtils to /tmp/pip-install-rv2yjdg2/clu_86f2533dee764118abfcaa9a269f8c66
  Running command git clone --filter=blob:none --quiet https://github.com/google/CommonLoopUtils /tmp/pip-install-rv2yjdg2/clu_86f2533dee764118abfcaa9a269f8c66
  Resolved https://github.com/google/CommonLoopUtils to commit 85f9d28556f2684e2c5f2e412cbef5119d6682ba
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Collecting flax@ git+https://github.com/google/flax#egg=flax
  Cloning https://github.com/google/flax to /tmp/pip-install-rv2yjdg2/flax_1a97969f56bb4cfab3b6a17417e6ae36
  Running command git clone --filter=blob:none --quiet https://github.com/google/flax /tmp/pip-install-rv2yjdg2/flax_1a97969f56bb4cfab3b6a17417e6ae36
  Resolved https://github.com/google/flax to commit 3747c8775c49ff524138c5e209b5280a8a605c13
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Collecting orbax@ git+https://github.com/google/orbax#egg=orbax
  Cloning https://github.com/google/orbax to /tmp/pip-install-rv2yjdg2/orbax_fb2aa390faf54a298e3118d7cde6c89e
  Running command git clone --filter=blob:none --quiet https://github.com/google/orbax /tmp/pip-install-rv2yjdg2/orbax_fb2aa390faf54a298e3118d7cde6c89e
  Resolved https://github.com/google/orbax to commit 60ac6d818c8b006fa65c0268e4985132e3693ef3
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Collecting seqio@ git+https://github.com/google/seqio#egg=seqio
  Cloning https://github.com/google/seqio to /tmp/pip-install-rv2yjdg2/seqio_784bb47b106b4e2a803a95eb5d3f01ab
  Running command git clone --filter=blob:none --quiet https://github.com/google/seqio /tmp/pip-install-rv2yjdg2/seqio_784bb47b106b4e2a803a95eb5d3f01ab
  Resolved https://github.com/google/seqio to commit ca7b5e5e7f0e609a0541cb143a99b3705d057cad
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: absl-py in /home/user/.local/lib/python3.8/site-packages (from t5x==0.0.0) (1.3.0)
Requirement already satisfied: cached_property in /home/user/.local/lib/python3.8/site-packages (from t5x==0.0.0) (1.5.2)
Requirement already satisfied: gin-config in /home/user/.local/lib/python3.8/site-packages (from t5x==0.0.0) (0.5.0)
Requirement already satisfied: jax>=0.2.27 in /home/user/.local/lib/python3.8/site-packages (from t5x==0.0.0) (0.3.23)
Requirement already satisfied: jaxlib>=0.1.76 in /home/user/.local/lib/python3.8/site-packages (from t5x==0.0.0) (0.3.22)
Requirement already satisfied: numpy in /home/user/.local/lib/python3.8/site-packages (from t5x==0.0.0) (1.23.4)
Requirement already satisfied: t5 in /home/user/.local/lib/python3.8/site-packages (from t5x==0.0.0) (0.9.3)
Collecting tensorflow-cpu
  Downloading tensorflow_cpu-2.10.0-cp38-cp38-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (214.4 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 214.4/214.4 MB 8.6 MB/s eta 0:00:00
Collecting tensorstore>=0.1.20
  Downloading tensorstore-0.1.27-cp38-cp38-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (8.1 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 8.1/8.1 MB 83.6 MB/s eta 0:00:00
Requirement already satisfied: typing-extensions in /home/user/.local/lib/python3.8/site-packages (from jax>=0.2.27->t5x==0.0.0) (4.4.0)
Requirement already satisfied: scipy>=1.5 in /home/user/.local/lib/python3.8/site-packages (from jax>=0.2.27->t5x==0.0.0) (1.9.3)
Requirement already satisfied: opt-einsum in /home/user/.local/lib/python3.8/site-packages (from jax>=0.2.27->t5x==0.0.0) (3.3.0)
Requirement already satisfied: etils[epath] in /home/user/.local/lib/python3.8/site-packages (from jax>=0.2.27->t5x==0.0.0) (0.8.0)
Requirement already satisfied: ml_collections in /home/user/.local/lib/python3.8/site-packages (from clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (0.1.1)
Requirement already satisfied: packaging in /home/user/.local/lib/python3.8/site-packages (from clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (20.9)
Requirement already satisfied: tensorflow in /home/user/.local/lib/python3.8/site-packages (from clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (2.10.0)
Requirement already satisfied: tensorflow_datasets in /home/user/.local/lib/python3.8/site-packages (from clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (4.7.0)
Requirement already satisfied: matplotlib in /home/user/.local/lib/python3.8/site-packages (from flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (3.6.1)
Requirement already satisfied: msgpack in /home/user/.local/lib/python3.8/site-packages (from flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (1.0.4)
Requirement already satisfied: optax in /home/user/.local/lib/python3.8/site-packages (from flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (0.1.3)
Requirement already satisfied: rich>=11.1 in /home/user/.local/lib/python3.8/site-packages (from flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (12.6.0)
Requirement already satisfied: PyYAML>=5.4.1 in /home/user/.local/lib/python3.8/site-packages (from flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (6.0)
Collecting dataclasses
  Downloading dataclasses-0.6-py3-none-any.whl (14 kB)
Requirement already satisfied: sentencepiece in /home/user/.local/lib/python3.8/site-packages (from seqio@ git+https://github.com/google/seqio#egg=seqio->t5x==0.0.0) (0.1.97)
Requirement already satisfied: tensorflow-text in /home/user/.local/lib/python3.8/site-packages (from seqio@ git+https://github.com/google/seqio#egg=seqio->t5x==0.0.0) (2.10.0)
Requirement already satisfied: tfds-nightly in /home/user/.local/lib/python3.8/site-packages (from seqio@ git+https://github.com/google/seqio#egg=seqio->t5x==0.0.0) (4.7.0.dev202210260046)
Requirement already satisfied: rouge-score in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (0.1.2)
Requirement already satisfied: pandas in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (1.5.1)
Requirement already satisfied: transformers>=2.7.0 in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (4.23.1)
Requirement already satisfied: torch in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (1.12.1)
Requirement already satisfied: mesh-tensorflow[transformer]>=0.1.13 in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (0.1.21)
Requirement already satisfied: six>=1.14 in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (1.16.0)
Requirement already satisfied: sacrebleu in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (2.3.1)
Requirement already satisfied: editdistance in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (0.6.0)
Requirement already satisfied: babel in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (2.10.3)
Requirement already satisfied: nltk in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (3.7)
Requirement already satisfied: scikit-learn in /home/user/.local/lib/python3.8/site-packages (from t5->t5x==0.0.0) (1.1.2)
Requirement already satisfied: keras<2.11,>=2.10.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-cpu->t5x==0.0.0) (2.10.0)
Requirement already satisfied: setuptools in /usr/local/lib/python3.8/site-packages (from tensorflow-cpu->t5x==0.0.0) (56.0.0)
Requirement already satisfied: flatbuffers>=2.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-cpu->t5x==0.0.0) (22.9.24)
Requirement already satisfied: wrapt>=1.11.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-cpu->t5x==0.0.0) (1.14.1)
Requirement already satisfied: termcolor>=1.1.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-cpu->t5x==0.0.0) (2.0.1)
Requirement already satisfied: tensorflow-estimator<2.11,>=2.10.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-cpu->t5x==0.0.0) (2.10.0)
Requirement already satisfied: tensorflow-io-gcs-filesystem>=0.23.1 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-cpu->t5x==0.0.0) (0.27.0)
Requirement already satisfied: protobuf<3.20,>=3.9.2 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-cpu->t5x==0.0.0) (3.19.6)
Requirement already satisfied: google-pasta>=0.1.1 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-cpu->t5x==0.0.0) (0.2.0)
Requirement already satisfied: h5py>=2.9.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-cpu->t5x==0.0.0) (3.7.0)
Requirement already satisfied: grpcio<2.0,>=1.24.3 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-cpu->t5x==0.0.0) (1.50.0)
Requirement already satisfied: tensorboard<2.11,>=2.10 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-cpu->t5x==0.0.0) (2.10.1)
Requirement already satisfied: gast<=0.4.0,>=0.2.1 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-cpu->t5x==0.0.0) (0.4.0)
Requirement already satisfied: astunparse>=1.6.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-cpu->t5x==0.0.0) (1.6.3)
Requirement already satisfied: keras-preprocessing>=1.1.1 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-cpu->t5x==0.0.0) (1.1.2)
Requirement already satisfied: libclang>=13.0.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-cpu->t5x==0.0.0) (14.0.6)
Requirement already satisfied: wheel<1.0,>=0.23.0 in /usr/local/lib/python3.8/site-packages (from astunparse>=1.6.0->tensorflow-cpu->t5x==0.0.0) (0.36.2)
Requirement already satisfied: future in /home/user/.local/lib/python3.8/site-packages (from mesh-tensorflow[transformer]>=0.1.13->t5->t5x==0.0.0) (0.18.2)
Requirement already satisfied: pygments<3.0.0,>=2.6.0 in /home/user/.local/lib/python3.8/site-packages (from rich>=11.1->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (2.13.0)
Requirement already satisfied: commonmark<0.10.0,>=0.9.0 in /home/user/.local/lib/python3.8/site-packages (from rich>=11.1->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (0.9.1)
Requirement already satisfied: tensorboard-plugin-wit>=1.6.0 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.11,>=2.10->tensorflow-cpu->t5x==0.0.0) (1.8.1)
Requirement already satisfied: markdown>=2.6.8 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.11,>=2.10->tensorflow-cpu->t5x==0.0.0) (3.4.1)
Requirement already satisfied: google-auth-oauthlib<0.5,>=0.4.1 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.11,>=2.10->tensorflow-cpu->t5x==0.0.0) (0.4.6)
Requirement already satisfied: werkzeug>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.11,>=2.10->tensorflow-cpu->t5x==0.0.0) (2.2.2)
Requirement already satisfied: requests<3,>=2.21.0 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.11,>=2.10->tensorflow-cpu->t5x==0.0.0) (2.28.1)
Requirement already satisfied: tensorboard-data-server<0.7.0,>=0.6.0 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.11,>=2.10->tensorflow-cpu->t5x==0.0.0) (0.6.1)
Requirement already satisfied: google-auth<3,>=1.6.3 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.11,>=2.10->tensorflow-cpu->t5x==0.0.0) (2.13.0)
Requirement already satisfied: huggingface-hub<1.0,>=0.10.0 in /home/user/.local/lib/python3.8/site-packages (from transformers>=2.7.0->t5->t5x==0.0.0) (0.10.1)
Requirement already satisfied: tokenizers!=0.11.3,<0.14,>=0.11.1 in /home/user/.local/lib/python3.8/site-packages (from transformers>=2.7.0->t5->t5x==0.0.0) (0.13.1)
Requirement already satisfied: tqdm>=4.27 in /home/user/.local/lib/python3.8/site-packages (from transformers>=2.7.0->t5->t5x==0.0.0) (4.64.1)
Requirement already satisfied: filelock in /home/user/.local/lib/python3.8/site-packages (from transformers>=2.7.0->t5->t5x==0.0.0) (3.8.0)
Requirement already satisfied: regex!=2019.12.17 in /home/user/.local/lib/python3.8/site-packages (from transformers>=2.7.0->t5->t5x==0.0.0) (2022.9.13)
Requirement already satisfied: pyparsing>=2.0.2 in /home/user/.local/lib/python3.8/site-packages (from packaging->clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (3.0.9)
Requirement already satisfied: pytz>=2015.7 in /home/user/.local/lib/python3.8/site-packages (from babel->t5->t5x==0.0.0) (2022.5)
Requirement already satisfied: zipp in /home/user/.local/lib/python3.8/site-packages (from etils[epath]->jax>=0.2.27->t5x==0.0.0) (3.10.0)
Requirement already satisfied: importlib_resources in /home/user/.local/lib/python3.8/site-packages (from etils[epath]->jax>=0.2.27->t5x==0.0.0) (5.10.0)
Requirement already satisfied: fonttools>=4.22.0 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (4.38.0)
Requirement already satisfied: kiwisolver>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (1.4.4)
Requirement already satisfied: pillow>=6.2.0 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (9.2.0)
Requirement already satisfied: python-dateutil>=2.7 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (2.8.2)
Requirement already satisfied: cycler>=0.10 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (0.11.0)
Requirement already satisfied: contourpy>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (1.0.5)
Requirement already satisfied: contextlib2 in /home/user/.local/lib/python3.8/site-packages (from ml_collections->clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (21.6.0)
Requirement already satisfied: joblib in /home/user/.local/lib/python3.8/site-packages (from nltk->t5->t5x==0.0.0) (1.2.0)
Requirement already satisfied: click in /home/user/.local/lib/python3.8/site-packages (from nltk->t5->t5x==0.0.0) (8.0.4)
Requirement already satisfied: chex>=0.0.4 in /home/user/.local/lib/python3.8/site-packages (from optax->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (0.1.5)
Requirement already satisfied: lxml in /home/user/.local/lib/python3.8/site-packages (from sacrebleu->t5->t5x==0.0.0) (4.9.1)
Requirement already satisfied: colorama in /home/user/.local/lib/python3.8/site-packages (from sacrebleu->t5->t5x==0.0.0) (0.4.6)
Requirement already satisfied: tabulate>=0.8.9 in /home/user/.local/lib/python3.8/site-packages (from sacrebleu->t5->t5x==0.0.0) (0.9.0)
Requirement already satisfied: portalocker in /home/user/.local/lib/python3.8/site-packages (from sacrebleu->t5->t5x==0.0.0) (2.6.0)
Requirement already satisfied: threadpoolctl>=2.0.0 in /home/user/.local/lib/python3.8/site-packages (from scikit-learn->t5->t5x==0.0.0) (3.1.0)
Requirement already satisfied: tensorflow-metadata in /home/user/.local/lib/python3.8/site-packages (from tensorflow_datasets->clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (1.10.0)
Requirement already satisfied: toml in /home/user/.local/lib/python3.8/site-packages (from tensorflow_datasets->clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (0.10.2)
Requirement already satisfied: dill in /home/user/.local/lib/python3.8/site-packages (from tensorflow_datasets->clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (0.3.5.1)
Requirement already satisfied: promise in /home/user/.local/lib/python3.8/site-packages (from tensorflow_datasets->clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (2.3)
Requirement already satisfied: tensorflow-hub>=0.8.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-text->seqio@ git+https://github.com/google/seqio#egg=seqio->t5x==0.0.0) (0.12.0)
Requirement already satisfied: dm-tree>=0.1.5 in /home/user/.local/lib/python3.8/site-packages (from chex>=0.0.4->optax->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (0.1.7)
Requirement already satisfied: toolz>=0.9.0 in /home/user/.local/lib/python3.8/site-packages (from chex>=0.0.4->optax->flax@ git+https://github.com/google/flax#egg=flax->t5x==0.0.0) (0.12.0)
Requirement already satisfied: rsa<5,>=3.1.4 in /home/user/.local/lib/python3.8/site-packages (from google-auth<3,>=1.6.3->tensorboard<2.11,>=2.10->tensorflow-cpu->t5x==0.0.0) (4.7.2)
Requirement already satisfied: pyasn1-modules>=0.2.1 in /home/user/.local/lib/python3.8/site-packages (from google-auth<3,>=1.6.3->tensorboard<2.11,>=2.10->tensorflow-cpu->t5x==0.0.0) (0.2.8)
Requirement already satisfied: cachetools<6.0,>=2.0.0 in /home/user/.local/lib/python3.8/site-packages (from google-auth<3,>=1.6.3->tensorboard<2.11,>=2.10->tensorflow-cpu->t5x==0.0.0) (5.2.0)
Requirement already satisfied: requests-oauthlib>=0.7.0 in /home/user/.local/lib/python3.8/site-packages (from google-auth-oauthlib<0.5,>=0.4.1->tensorboard<2.11,>=2.10->tensorflow-cpu->t5x==0.0.0) (1.3.1)
Requirement already satisfied: importlib-metadata>=4.4 in /home/user/.local/lib/python3.8/site-packages (from markdown>=2.6.8->tensorboard<2.11,>=2.10->tensorflow-cpu->t5x==0.0.0) (5.0.0)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in /home/user/.local/lib/python3.8/site-packages (from requests<3,>=2.21.0->tensorboard<2.11,>=2.10->tensorflow-cpu->t5x==0.0.0) (1.26.12)
Requirement already satisfied: certifi>=2017.4.17 in /home/user/.local/lib/python3.8/site-packages (from requests<3,>=2.21.0->tensorboard<2.11,>=2.10->tensorflow-cpu->t5x==0.0.0) (2022.9.24)
Requirement already satisfied: charset-normalizer<3,>=2 in /home/user/.local/lib/python3.8/site-packages (from requests<3,>=2.21.0->tensorboard<2.11,>=2.10->tensorflow-cpu->t5x==0.0.0) (2.1.1)
Requirement already satisfied: idna<4,>=2.5 in /home/user/.local/lib/python3.8/site-packages (from requests<3,>=2.21.0->tensorboard<2.11,>=2.10->tensorflow-cpu->t5x==0.0.0) (3.4)
Requirement already satisfied: MarkupSafe>=2.1.1 in /home/user/.local/lib/python3.8/site-packages (from werkzeug>=1.0.1->tensorboard<2.11,>=2.10->tensorflow-cpu->t5x==0.0.0) (2.1.1)
Requirement already satisfied: googleapis-common-protos<2,>=1.52.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-metadata->tensorflow_datasets->clu@ git+https://github.com/google/CommonLoopUtils#egg=clu->t5x==0.0.0) (1.56.4)
Requirement already satisfied: pyasn1<0.5.0,>=0.4.6 in /home/user/.local/lib/python3.8/site-packages (from pyasn1-modules>=0.2.1->google-auth<3,>=1.6.3->tensorboard<2.11,>=2.10->tensorflow-cpu->t5x==0.0.0) (0.4.8)
Requirement already satisfied: oauthlib>=3.0.0 in /home/user/.local/lib/python3.8/site-packages (from requests-oauthlib>=0.7.0->google-auth-oauthlib<0.5,>=0.4.1->tensorboard<2.11,>=2.10->tensorflow-cpu->t5x==0.0.0) (3.2.2)
Building wheels for collected packages: orbax
  Building wheel for orbax (setup.py): started
  Building wheel for orbax (setup.py): finished with status 'done'
  Created wheel for orbax: filename=orbax-0.0.13-py3-none-any.whl size=54308 sha256=b9f0a8ffbbc3d61b87edd8c774ff9413bbc3073b8083016447f75eac4fa463e5
  Stored in directory: /tmp/pip-ephem-wheel-cache-kg3tztjq/wheels/3d/82/c5/2cac0927cf78e3edfdec5d06d17ab46302436e3a0c5e28b52d
Successfully built orbax
Installing collected packages: dataclasses, tensorstore, tensorflow-cpu, orbax, t5x
  Running setup.py develop for t5x
Successfully installed dataclasses-0.6 orbax-0.0.13 t5x tensorflow-cpu-2.10.0 tensorstore-0.1.27
WARNING: You are using pip version 22.0.2; however, version 22.3 is available.
You should consider upgrading via the '/usr/local/bin/python3 -m pip install --upgrade pip' command.
Cloning into 'mt3'...
Defaulting to user installation because normal site-packages is not writeable
Obtaining file:///home/user/app
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Collecting absl-py==1.1.0
  Downloading absl_py-1.1.0-py3-none-any.whl (123 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 123.7/123.7 KB 13.6 MB/s eta 0:00:00
Collecting ddsp==3.4.4
  Downloading ddsp-3.4.4-py2.py3-none-any.whl (212 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 212.5/212.5 KB 34.5 MB/s eta 0:00:00
Collecting flax==0.5.2
  Downloading flax-0.5.2-py3-none-any.whl (197 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 197.1/197.1 KB 21.8 MB/s eta 0:00:00
Requirement already satisfied: gin-config==0.5.0 in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (0.5.0)
Requirement already satisfied: immutabledict==2.2.1 in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (2.2.1)
Requirement already satisfied: librosa==0.9.2 in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (0.9.2)
Requirement already satisfied: mir_eval==0.7 in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (0.7)
Requirement already satisfied: note_seq==0.0.3 in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (0.0.3)
Collecting numpy==1.21.6
  Downloading numpy-1.21.6-cp38-cp38-manylinux_2_12_x86_64.manylinux2010_x86_64.whl (15.7 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 15.7/15.7 MB 79.4 MB/s eta 0:00:00
Requirement already satisfied: pretty_midi==0.2.9 in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (0.2.9)
Collecting scikit-learn==1.0.2
  Downloading scikit_learn-1.0.2-cp38-cp38-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (26.7 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 26.7/26.7 MB 71.8 MB/s eta 0:00:00
Collecting scipy==1.7.3
  Downloading scipy-1.7.3-cp38-cp38-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (39.3 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 39.3/39.3 MB 56.8 MB/s eta 0:00:00
Collecting seqio==0.0.8
  Downloading seqio-0.0.8-py3-none-any.whl (305 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 305.6/305.6 KB 58.7 MB/s eta 0:00:00
Requirement already satisfied: t5==0.9.3 in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (0.9.3)
Requirement already satisfied: tensorflow in /home/user/.local/lib/python3.8/site-packages (from mt3==0.0.1) (2.10.0)
Collecting tensorflow-datasets==4.6.0
  Downloading tensorflow_datasets-4.6.0-py3-none-any.whl (4.3 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 4.3/4.3 MB 117.7 MB/s eta 0:00:00
Requirement already satisfied: future in /home/user/.local/lib/python3.8/site-packages (from ddsp==3.4.4->mt3==0.0.1) (0.18.2)
Collecting numba<0.50
  Downloading numba-0.49.1-cp38-cp38-manylinux2014_x86_64.whl (3.6 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 3.6/3.6 MB 113.3 MB/s eta 0:00:00
Requirement already satisfied: tensorflow-addons in /home/user/.local/lib/python3.8/site-packages (from ddsp==3.4.4->mt3==0.0.1) (0.18.0)
Requirement already satisfied: six in /home/user/.local/lib/python3.8/site-packages (from ddsp==3.4.4->mt3==0.0.1) (1.16.0)
Requirement already satisfied: tensorflow-probability in /home/user/.local/lib/python3.8/site-packages (from ddsp==3.4.4->mt3==0.0.1) (0.18.0)
Requirement already satisfied: cloudml-hypertune in /home/user/.local/lib/python3.8/site-packages (from ddsp==3.4.4->mt3==0.0.1) (0.1.0.dev6)
Requirement already satisfied: tensorflowjs in /home/user/.local/lib/python3.8/site-packages (from ddsp==3.4.4->mt3==0.0.1) (3.18.0)
Requirement already satisfied: google-cloud-storage in /home/user/.local/lib/python3.8/site-packages (from ddsp==3.4.4->mt3==0.0.1) (2.5.0)
Requirement already satisfied: crepe>=0.0.11 in /home/user/.local/lib/python3.8/site-packages (from ddsp==3.4.4->mt3==0.0.1) (0.0.12)
Requirement already satisfied: tflite-support in /home/user/.local/lib/python3.8/site-packages (from ddsp==3.4.4->mt3==0.0.1) (0.4.2)
Requirement already satisfied: pydub in /home/user/.local/lib/python3.8/site-packages (from ddsp==3.4.4->mt3==0.0.1) (0.25.1)
Requirement already satisfied: PyYAML>=5.4.1 in /home/user/.local/lib/python3.8/site-packages (from flax==0.5.2->mt3==0.0.1) (6.0)
Requirement already satisfied: msgpack in /home/user/.local/lib/python3.8/site-packages (from flax==0.5.2->mt3==0.0.1) (1.0.4)
Requirement already satisfied: matplotlib in /home/user/.local/lib/python3.8/site-packages (from flax==0.5.2->mt3==0.0.1) (3.6.1)
Requirement already satisfied: optax in /home/user/.local/lib/python3.8/site-packages (from flax==0.5.2->mt3==0.0.1) (0.1.3)
Collecting rich~=11.1
  Downloading rich-11.2.0-py3-none-any.whl (217 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 217.3/217.3 KB 32.6 MB/s eta 0:00:00
Requirement already satisfied: jax>=0.3.2 in /home/user/.local/lib/python3.8/site-packages (from flax==0.5.2->mt3==0.0.1) (0.3.23)
Requirement already satisfied: typing-extensions>=4.1.1 in /home/user/.local/lib/python3.8/site-packages (from flax==0.5.2->mt3==0.0.1) (4.4.0)
Requirement already satisfied: audioread>=2.1.9 in /home/user/.local/lib/python3.8/site-packages (from librosa==0.9.2->mt3==0.0.1) (3.0.0)
Requirement already satisfied: soundfile>=0.10.2 in /home/user/.local/lib/python3.8/site-packages (from librosa==0.9.2->mt3==0.0.1) (0.11.0)
Requirement already satisfied: packaging>=20.0 in /home/user/.local/lib/python3.8/site-packages (from librosa==0.9.2->mt3==0.0.1) (20.9)
Requirement already satisfied: resampy>=0.2.2 in /home/user/.local/lib/python3.8/site-packages (from librosa==0.9.2->mt3==0.0.1) (0.2.2)
Requirement already satisfied: joblib>=0.14 in /home/user/.local/lib/python3.8/site-packages (from librosa==0.9.2->mt3==0.0.1) (1.2.0)
Requirement already satisfied: pooch>=1.0 in /home/user/.local/lib/python3.8/site-packages (from librosa==0.9.2->mt3==0.0.1) (1.6.0)
Requirement already satisfied: decorator>=4.0.10 in /home/user/.local/lib/python3.8/site-packages (from librosa==0.9.2->mt3==0.0.1) (5.1.1)
Requirement already satisfied: pandas>=0.18.1 in /home/user/.local/lib/python3.8/site-packages (from note_seq==0.0.3->mt3==0.0.1) (1.5.1)
Requirement already satisfied: attrs in /home/user/.local/lib/python3.8/site-packages (from note_seq==0.0.3->mt3==0.0.1) (22.1.0)
Requirement already satisfied: intervaltree>=2.1.0 in /home/user/.local/lib/python3.8/site-packages (from note_seq==0.0.3->mt3==0.0.1) (3.1.0)
Requirement already satisfied: bokeh>=0.12.0 in /home/user/.local/lib/python3.8/site-packages (from note_seq==0.0.3->mt3==0.0.1) (2.4.3)
Requirement already satisfied: protobuf>=3.6.1 in /home/user/.local/lib/python3.8/site-packages (from note_seq==0.0.3->mt3==0.0.1) (3.19.6)
Requirement already satisfied: IPython in /home/user/.local/lib/python3.8/site-packages (from note_seq==0.0.3->mt3==0.0.1) (8.5.0)
Requirement already satisfied: mido>=1.1.16 in /home/user/.local/lib/python3.8/site-packages (from pretty_midi==0.2.9->mt3==0.0.1) (1.2.10)
Requirement already satisfied: threadpoolctl>=2.0.0 in /home/user/.local/lib/python3.8/site-packages (from scikit-learn==1.0.2->mt3==0.0.1) (3.1.0)
Requirement already satisfied: sentencepiece in /home/user/.local/lib/python3.8/site-packages (from seqio==0.0.8->mt3==0.0.1) (0.1.97)
Requirement already satisfied: tensorflow-text in /home/user/.local/lib/python3.8/site-packages (from seqio==0.0.8->mt3==0.0.1) (2.10.0)
Requirement already satisfied: tfds-nightly in /home/user/.local/lib/python3.8/site-packages (from seqio==0.0.8->mt3==0.0.1) (4.7.0.dev202210260046)
Requirement already satisfied: torch in /home/user/.local/lib/python3.8/site-packages (from t5==0.9.3->mt3==0.0.1) (1.12.1)
Requirement already satisfied: mesh-tensorflow[transformer]>=0.1.13 in /home/user/.local/lib/python3.8/site-packages (from t5==0.9.3->mt3==0.0.1) (0.1.21)
Requirement already satisfied: transformers>=2.7.0 in /home/user/.local/lib/python3.8/site-packages (from t5==0.9.3->mt3==0.0.1) (4.23.1)
Requirement already satisfied: nltk in /home/user/.local/lib/python3.8/site-packages (from t5==0.9.3->mt3==0.0.1) (3.7)
Requirement already satisfied: babel in /home/user/.local/lib/python3.8/site-packages (from t5==0.9.3->mt3==0.0.1) (2.10.3)
Requirement already satisfied: editdistance in /home/user/.local/lib/python3.8/site-packages (from t5==0.9.3->mt3==0.0.1) (0.6.0)
Requirement already satisfied: sacrebleu in /home/user/.local/lib/python3.8/site-packages (from t5==0.9.3->mt3==0.0.1) (2.3.1)
Requirement already satisfied: rouge-score in /home/user/.local/lib/python3.8/site-packages (from t5==0.9.3->mt3==0.0.1) (0.1.2)
Requirement already satisfied: tensorflow-metadata in /home/user/.local/lib/python3.8/site-packages (from tensorflow-datasets==4.6.0->mt3==0.0.1) (1.10.0)
Requirement already satisfied: importlib-resources in /home/user/.local/lib/python3.8/site-packages (from tensorflow-datasets==4.6.0->mt3==0.0.1) (5.10.0)
Requirement already satisfied: termcolor in /home/user/.local/lib/python3.8/site-packages (from tensorflow-datasets==4.6.0->mt3==0.0.1) (2.0.1)
Requirement already satisfied: toml in /home/user/.local/lib/python3.8/site-packages (from tensorflow-datasets==4.6.0->mt3==0.0.1) (0.10.2)
Requirement already satisfied: tqdm in /home/user/.local/lib/python3.8/site-packages (from tensorflow-datasets==4.6.0->mt3==0.0.1) (4.64.1)
Requirement already satisfied: promise in /home/user/.local/lib/python3.8/site-packages (from tensorflow-datasets==4.6.0->mt3==0.0.1) (2.3)
Requirement already satisfied: etils[epath] in /home/user/.local/lib/python3.8/site-packages (from tensorflow-datasets==4.6.0->mt3==0.0.1) (0.8.0)
Requirement already satisfied: requests>=2.19.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-datasets==4.6.0->mt3==0.0.1) (2.28.1)
Requirement already satisfied: dill in /home/user/.local/lib/python3.8/site-packages (from tensorflow-datasets==4.6.0->mt3==0.0.1) (0.3.5.1)
Requirement already satisfied: keras<2.11,>=2.10.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (2.10.0)
Requirement already satisfied: libclang>=13.0.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (14.0.6)
Requirement already satisfied: h5py>=2.9.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (3.7.0)
Requirement already satisfied: grpcio<2.0,>=1.24.3 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (1.50.0)
Requirement already satisfied: tensorboard<2.11,>=2.10 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (2.10.1)
Requirement already satisfied: wrapt>=1.11.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (1.14.1)
Requirement already satisfied: google-pasta>=0.1.1 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (0.2.0)
Requirement already satisfied: keras-preprocessing>=1.1.1 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (1.1.2)
Requirement already satisfied: tensorflow-io-gcs-filesystem>=0.23.1 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (0.27.0)
Requirement already satisfied: astunparse>=1.6.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (1.6.3)
Requirement already satisfied: flatbuffers>=2.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (22.9.24)
Requirement already satisfied: gast<=0.4.0,>=0.2.1 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (0.4.0)
Requirement already satisfied: setuptools in /usr/local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (56.0.0)
Requirement already satisfied: tensorflow-estimator<2.11,>=2.10.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (2.10.0)
Requirement already satisfied: opt-einsum>=2.3.2 in /home/user/.local/lib/python3.8/site-packages (from tensorflow->mt3==0.0.1) (3.3.0)
Requirement already satisfied: wheel<1.0,>=0.23.0 in /usr/local/lib/python3.8/site-packages (from astunparse>=1.6.0->tensorflow->mt3==0.0.1) (0.36.2)
Requirement already satisfied: tornado>=5.1 in /home/user/.local/lib/python3.8/site-packages (from bokeh>=0.12.0->note_seq==0.0.3->mt3==0.0.1) (6.2)
Requirement already satisfied: pillow>=7.1.0 in /home/user/.local/lib/python3.8/site-packages (from bokeh>=0.12.0->note_seq==0.0.3->mt3==0.0.1) (9.2.0)
Requirement already satisfied: Jinja2>=2.9 in /home/user/.local/lib/python3.8/site-packages (from bokeh>=0.12.0->note_seq==0.0.3->mt3==0.0.1) (3.1.2)
Requirement already satisfied: hmmlearn<0.3.0,>=0.2.0 in /home/user/.local/lib/python3.8/site-packages (from crepe>=0.0.11->ddsp==3.4.4->mt3==0.0.1) (0.2.7)
Requirement already satisfied: imageio>=2.3.0 in /home/user/.local/lib/python3.8/site-packages (from crepe>=0.0.11->ddsp==3.4.4->mt3==0.0.1) (2.22.2)
Requirement already satisfied: sortedcontainers<3.0,>=2.0 in /home/user/.local/lib/python3.8/site-packages (from intervaltree>=2.1.0->note_seq==0.0.3->mt3==0.0.1) (2.4.0)
Requirement already satisfied: kiwisolver>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax==0.5.2->mt3==0.0.1) (1.4.4)
Requirement already satisfied: pyparsing>=2.2.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax==0.5.2->mt3==0.0.1) (3.0.9)
Requirement already satisfied: fonttools>=4.22.0 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax==0.5.2->mt3==0.0.1) (4.38.0)
Requirement already satisfied: cycler>=0.10 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax==0.5.2->mt3==0.0.1) (0.11.0)
Requirement already satisfied: contourpy>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax==0.5.2->mt3==0.0.1) (1.0.5)
Requirement already satisfied: python-dateutil>=2.7 in /home/user/.local/lib/python3.8/site-packages (from matplotlib->flax==0.5.2->mt3==0.0.1) (2.8.2)
Collecting llvmlite<=0.33.0.dev0,>=0.31.0.dev0
  Downloading llvmlite-0.32.1-cp38-cp38-manylinux1_x86_64.whl (20.2 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 20.2/20.2 MB 92.2 MB/s eta 0:00:00
Requirement already satisfied: pytz>=2020.1 in /home/user/.local/lib/python3.8/site-packages (from pandas>=0.18.1->note_seq==0.0.3->mt3==0.0.1) (2022.5)
Requirement already satisfied: appdirs>=1.3.0 in /home/user/.local/lib/python3.8/site-packages (from pooch>=1.0->librosa==0.9.2->mt3==0.0.1) (1.4.4)
Requirement already satisfied: charset-normalizer<3,>=2 in /home/user/.local/lib/python3.8/site-packages (from requests>=2.19.0->tensorflow-datasets==4.6.0->mt3==0.0.1) (2.1.1)
Requirement already satisfied: idna<4,>=2.5 in /home/user/.local/lib/python3.8/site-packages (from requests>=2.19.0->tensorflow-datasets==4.6.0->mt3==0.0.1) (3.4)
Requirement already satisfied: certifi>=2017.4.17 in /home/user/.local/lib/python3.8/site-packages (from requests>=2.19.0->tensorflow-datasets==4.6.0->mt3==0.0.1) (2022.9.24)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in /home/user/.local/lib/python3.8/site-packages (from requests>=2.19.0->tensorflow-datasets==4.6.0->mt3==0.0.1) (1.26.12)
Requirement already satisfied: pygments<3.0.0,>=2.6.0 in /home/user/.local/lib/python3.8/site-packages (from rich~=11.1->flax==0.5.2->mt3==0.0.1) (2.13.0)
Requirement already satisfied: commonmark<0.10.0,>=0.9.0 in /home/user/.local/lib/python3.8/site-packages (from rich~=11.1->flax==0.5.2->mt3==0.0.1) (0.9.1)
Requirement already satisfied: colorama<0.5.0,>=0.4.0 in /home/user/.local/lib/python3.8/site-packages (from rich~=11.1->flax==0.5.2->mt3==0.0.1) (0.4.6)
Requirement already satisfied: cffi>=1.0 in /home/user/.local/lib/python3.8/site-packages (from soundfile>=0.10.2->librosa==0.9.2->mt3==0.0.1) (1.15.1)
Requirement already satisfied: google-auth-oauthlib<0.5,>=0.4.1 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.11,>=2.10->tensorflow->mt3==0.0.1) (0.4.6)
Requirement already satisfied: werkzeug>=1.0.1 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.11,>=2.10->tensorflow->mt3==0.0.1) (2.2.2)
Requirement already satisfied: tensorboard-data-server<0.7.0,>=0.6.0 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.11,>=2.10->tensorflow->mt3==0.0.1) (0.6.1)
Requirement already satisfied: google-auth<3,>=1.6.3 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.11,>=2.10->tensorflow->mt3==0.0.1) (2.13.0)
Requirement already satisfied: tensorboard-plugin-wit>=1.6.0 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.11,>=2.10->tensorflow->mt3==0.0.1) (1.8.1)
Requirement already satisfied: markdown>=2.6.8 in /home/user/.local/lib/python3.8/site-packages (from tensorboard<2.11,>=2.10->tensorflow->mt3==0.0.1) (3.4.1)
Requirement already satisfied: regex!=2019.12.17 in /home/user/.local/lib/python3.8/site-packages (from transformers>=2.7.0->t5==0.9.3->mt3==0.0.1) (2022.9.13)
Requirement already satisfied: tokenizers!=0.11.3,<0.14,>=0.11.1 in /home/user/.local/lib/python3.8/site-packages (from transformers>=2.7.0->t5==0.9.3->mt3==0.0.1) (0.13.1)
Requirement already satisfied: huggingface-hub<1.0,>=0.10.0 in /home/user/.local/lib/python3.8/site-packages (from transformers>=2.7.0->t5==0.9.3->mt3==0.0.1) (0.10.1)
Requirement already satisfied: filelock in /home/user/.local/lib/python3.8/site-packages (from transformers>=2.7.0->t5==0.9.3->mt3==0.0.1) (3.8.0)
Requirement already satisfied: zipp in /home/user/.local/lib/python3.8/site-packages (from etils[epath]->tensorflow-datasets==4.6.0->mt3==0.0.1) (3.10.0)
Requirement already satisfied: google-resumable-media>=2.3.2 in /home/user/.local/lib/python3.8/site-packages (from google-cloud-storage->ddsp==3.4.4->mt3==0.0.1) (2.4.0)
Requirement already satisfied: google-api-core!=2.0.*,!=2.1.*,!=2.2.*,!=2.3.0,<3.0.0dev,>=1.31.5 in /home/user/.local/lib/python3.8/site-packages (from google-cloud-storage->ddsp==3.4.4->mt3==0.0.1) (2.10.2)
Requirement already satisfied: google-cloud-core<3.0dev,>=2.3.0 in /home/user/.local/lib/python3.8/site-packages (from google-cloud-storage->ddsp==3.4.4->mt3==0.0.1) (2.3.2)
Requirement already satisfied: prompt-toolkit<3.1.0,>3.0.1 in /home/user/.local/lib/python3.8/site-packages (from IPython->note_seq==0.0.3->mt3==0.0.1) (3.0.31)
Requirement already satisfied: stack-data in /home/user/.local/lib/python3.8/site-packages (from IPython->note_seq==0.0.3->mt3==0.0.1) (0.5.1)
Requirement already satisfied: pickleshare in /home/user/.local/lib/python3.8/site-packages (from IPython->note_seq==0.0.3->mt3==0.0.1) (0.7.5)
Requirement already satisfied: matplotlib-inline in /home/user/.local/lib/python3.8/site-packages (from IPython->note_seq==0.0.3->mt3==0.0.1) (0.1.6)
Requirement already satisfied: backcall in /home/user/.local/lib/python3.8/site-packages (from IPython->note_seq==0.0.3->mt3==0.0.1) (0.2.0)
Requirement already satisfied: traitlets>=5 in /home/user/.local/lib/python3.8/site-packages (from IPython->note_seq==0.0.3->mt3==0.0.1) (5.5.0)
Requirement already satisfied: jedi>=0.16 in /home/user/.local/lib/python3.8/site-packages (from IPython->note_seq==0.0.3->mt3==0.0.1) (0.18.1)
Requirement already satisfied: pexpect>4.3 in /home/user/.local/lib/python3.8/site-packages (from IPython->note_seq==0.0.3->mt3==0.0.1) (4.8.0)
Requirement already satisfied: click in /home/user/.local/lib/python3.8/site-packages (from nltk->t5==0.9.3->mt3==0.0.1) (8.0.4)
Requirement already satisfied: chex>=0.0.4 in /home/user/.local/lib/python3.8/site-packages (from optax->flax==0.5.2->mt3==0.0.1) (0.1.5)
Requirement already satisfied: jaxlib>=0.1.37 in /home/user/.local/lib/python3.8/site-packages (from optax->flax==0.5.2->mt3==0.0.1) (0.3.22)
Requirement already satisfied: portalocker in /home/user/.local/lib/python3.8/site-packages (from sacrebleu->t5==0.9.3->mt3==0.0.1) (2.6.0)
Requirement already satisfied: lxml in /home/user/.local/lib/python3.8/site-packages (from sacrebleu->t5==0.9.3->mt3==0.0.1) (4.9.1)
Requirement already satisfied: tabulate>=0.8.9 in /home/user/.local/lib/python3.8/site-packages (from sacrebleu->t5==0.9.3->mt3==0.0.1) (0.9.0)
Requirement already satisfied: typeguard>=2.7 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-addons->ddsp==3.4.4->mt3==0.0.1) (2.13.3)
Requirement already satisfied: googleapis-common-protos<2,>=1.52.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-metadata->tensorflow-datasets==4.6.0->mt3==0.0.1) (1.56.4)
Requirement already satisfied: cloudpickle>=1.3 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-probability->ddsp==3.4.4->mt3==0.0.1) (2.2.0)
Requirement already satisfied: dm-tree in /home/user/.local/lib/python3.8/site-packages (from tensorflow-probability->ddsp==3.4.4->mt3==0.0.1) (0.1.7)
Requirement already satisfied: tensorflow-hub>=0.8.0 in /home/user/.local/lib/python3.8/site-packages (from tensorflow-text->seqio==0.0.8->mt3==0.0.1) (0.12.0)
Requirement already satisfied: sounddevice>=0.4.4 in /home/user/.local/lib/python3.8/site-packages (from tflite-support->ddsp==3.4.4->mt3==0.0.1) (0.4.5)
Requirement already satisfied: pybind11>=2.6.0 in /home/user/.local/lib/python3.8/site-packages (from tflite-support->ddsp==3.4.4->mt3==0.0.1) (2.10.0)
Requirement already satisfied: pycparser in /home/user/.local/lib/python3.8/site-packages (from cffi>=1.0->soundfile>=0.10.2->librosa==0.9.2->mt3==0.0.1) (2.21)
Requirement already satisfied: toolz>=0.9.0 in /home/user/.local/lib/python3.8/site-packages (from chex>=0.0.4->optax->flax==0.5.2->mt3==0.0.1) (0.12.0)
Requirement already satisfied: cachetools<6.0,>=2.0.0 in /home/user/.local/lib/python3.8/site-packages (from google-auth<3,>=1.6.3->tensorboard<2.11,>=2.10->tensorflow->mt3==0.0.1) (5.2.0)
Requirement already satisfied: rsa<5,>=3.1.4 in /home/user/.local/lib/python3.8/site-packages (from google-auth<3,>=1.6.3->tensorboard<2.11,>=2.10->tensorflow->mt3==0.0.1) (4.7.2)
Requirement already satisfied: pyasn1-modules>=0.2.1 in /home/user/.local/lib/python3.8/site-packages (from google-auth<3,>=1.6.3->tensorboard<2.11,>=2.10->tensorflow->mt3==0.0.1) (0.2.8)
Requirement already satisfied: requests-oauthlib>=0.7.0 in /home/user/.local/lib/python3.8/site-packages (from google-auth-oauthlib<0.5,>=0.4.1->tensorboard<2.11,>=2.10->tensorflow->mt3==0.0.1) (1.3.1)
Requirement already satisfied: google-crc32c<2.0dev,>=1.0 in /home/user/.local/lib/python3.8/site-packages (from google-resumable-media>=2.3.2->google-cloud-storage->ddsp==3.4.4->mt3==0.0.1) (1.5.0)
Requirement already satisfied: parso<0.9.0,>=0.8.0 in /home/user/.local/lib/python3.8/site-packages (from jedi>=0.16->IPython->note_seq==0.0.3->mt3==0.0.1) (0.8.3)
Requirement already satisfied: MarkupSafe>=2.0 in /home/user/.local/lib/python3.8/site-packages (from Jinja2>=2.9->bokeh>=0.12.0->note_seq==0.0.3->mt3==0.0.1) (2.1.1)
Requirement already satisfied: importlib-metadata>=4.4 in /home/user/.local/lib/python3.8/site-packages (from markdown>=2.6.8->tensorboard<2.11,>=2.10->tensorflow->mt3==0.0.1) (5.0.0)
Requirement already satisfied: ptyprocess>=0.5 in /home/user/.local/lib/python3.8/site-packages (from pexpect>4.3->IPython->note_seq==0.0.3->mt3==0.0.1) (0.7.0)
Requirement already satisfied: wcwidth in /home/user/.local/lib/python3.8/site-packages (from prompt-toolkit<3.1.0,>3.0.1->IPython->note_seq==0.0.3->mt3==0.0.1) (0.2.5)
Requirement already satisfied: asttokens in /home/user/.local/lib/python3.8/site-packages (from stack-data->IPython->note_seq==0.0.3->mt3==0.0.1) (2.0.8)
Requirement already satisfied: pure-eval in /home/user/.local/lib/python3.8/site-packages (from stack-data->IPython->note_seq==0.0.3->mt3==0.0.1) (0.2.2)
Requirement already satisfied: executing in /home/user/.local/lib/python3.8/site-packages (from stack-data->IPython->note_seq==0.0.3->mt3==0.0.1) (1.1.1)
Requirement already satisfied: pyasn1<0.5.0,>=0.4.6 in /home/user/.local/lib/python3.8/site-packages (from pyasn1-modules>=0.2.1->google-auth<3,>=1.6.3->tensorboard<2.11,>=2.10->tensorflow->mt3==0.0.1) (0.4.8)
Requirement already satisfied: oauthlib>=3.0.0 in /home/user/.local/lib/python3.8/site-packages (from requests-oauthlib>=0.7.0->google-auth-oauthlib<0.5,>=0.4.1->tensorboard<2.11,>=2.10->tensorflow->mt3==0.0.1) (3.2.2)
Installing collected packages: llvmlite, rich, numpy, absl-py, scipy, numba, tensorflow-datasets, scikit-learn, flax, seqio, ddsp, mt3
  Attempting uninstall: llvmlite
    Found existing installation: llvmlite 0.39.1
    Uninstalling llvmlite-0.39.1:
      Successfully uninstalled llvmlite-0.39.1
  Attempting uninstall: rich
    Found existing installation: rich 12.6.0
    Uninstalling rich-12.6.0:
      Successfully uninstalled rich-12.6.0
  Attempting uninstall: numpy
    Found existing installation: numpy 1.23.4
    Uninstalling numpy-1.23.4:
      Successfully uninstalled numpy-1.23.4
  Attempting uninstall: absl-py
    Found existing installation: absl-py 1.3.0
    Uninstalling absl-py-1.3.0:
      Successfully uninstalled absl-py-1.3.0
  Attempting uninstall: scipy
    Found existing installation: scipy 1.9.3
    Uninstalling scipy-1.9.3:
      Successfully uninstalled scipy-1.9.3
  Attempting uninstall: numba
    Found existing installation: numba 0.56.3
    Uninstalling numba-0.56.3:
      Successfully uninstalled numba-0.56.3
  Attempting uninstall: tensorflow-datasets
    Found existing installation: tensorflow-datasets 4.7.0
    Uninstalling tensorflow-datasets-4.7.0:
      Successfully uninstalled tensorflow-datasets-4.7.0
  Attempting uninstall: scikit-learn
    Found existing installation: scikit-learn 1.1.2
    Uninstalling scikit-learn-1.1.2:
      Successfully uninstalled scikit-learn-1.1.2
  Attempting uninstall: flax
    Found existing installation: flax 0.6.1
    Uninstalling flax-0.6.1:
      Successfully uninstalled flax-0.6.1
  Attempting uninstall: seqio
    Found existing installation: seqio 0.0.11
    Uninstalling seqio-0.0.11:
      Successfully uninstalled seqio-0.0.11
  Attempting uninstall: ddsp
    Found existing installation: ddsp 3.5.0
    Uninstalling ddsp-3.5.0:
      Successfully uninstalled ddsp-3.5.0
  Running setup.py develop for mt3
Successfully installed absl-py-1.1.0 ddsp-3.4.4 flax-0.5.2 llvmlite-0.32.1 mt3 numba-0.49.1 numpy-1.21.6 rich-11.2.0 scikit-learn-1.0.2 scipy-1.7.3 seqio-0.0.8 tensorflow-datasets-4.6.0
WARNING: You are using pip version 22.0.2; however, version 22.3 is available.
You should consider upgrading via the '/usr/local/bin/python3 -m pip install --upgrade pip' command.
2022-10-26 05:39:57.352377: I tensorflow/core/platform/cpu_feature_guard.cc:193] This TensorFlow binary is optimized with oneAPI Deep Neural Network Library (oneDNN) to use the following CPU instructions in performance-critical operations:  AVX2 AVX512F FMA
To enable them in other operations, rebuild TensorFlow with the appropriate compiler flags.
/home/user/.local/lib/python3.8/site-packages/scipy/__init__.py:146: UserWarning: A NumPy version >=1.16.5 and <1.23.0 is required for this version of SciPy (detected version 1.23.4
  warnings.warn(f"A NumPy version >={np_minversion} and <{np_maxversion}"
Traceback (most recent call last):
  File "app.py", line 263, in <module>
    inference_model = InferenceModel('/home/user/app/checkpoints/mt3/', 'mt3')
  File "app.py", line 88, in __init__
    self.partitioner = t5x.partitioning.ModelBasedPjitPartitioner(
AttributeError: module 't5x.partitioning' has no attribute 'ModelBasedPjitPartitioner'