Spaces:
Runtime error

runtime error

Space not ready. Reason: Error

Container logs:

Cloning into 'fairseq'...
Defaulting to user installation because normal site-packages is not writeable
DEPRECATION: In-tree builds are now the default. pip 22.1 will enforce this behaviour change. A possible replacement is to remove the --use-feature=in-tree-build flag.
Processing /home/user/app/fairseq
  Installing build dependencies: started
  Installing build dependencies: finished with status 'done'
  Getting requirements to build wheel: started
  Getting requirements to build wheel: finished with status 'done'
  Installing backend dependencies: started
  Installing backend dependencies: finished with status 'done'
  Preparing metadata (pyproject.toml): started
  Preparing metadata (pyproject.toml): finished with status 'done'
Collecting cython
  Using cached Cython-0.29.32-cp38-cp38-manylinux_2_17_x86_64.manylinux2014_x86_64.manylinux_2_24_x86_64.whl (1.9 MB)
Collecting bitarray
  Downloading bitarray-2.6.0-cp38-cp38-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (241 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 241.4/241.4 KB 27.2 MB/s eta 0:00:00
Requirement already satisfied: numpy in /home/user/.local/lib/python3.8/site-packages (from fairseq==0.12.2) (1.22.4)
Requirement already satisfied: tqdm in /home/user/.local/lib/python3.8/site-packages (from fairseq==0.12.2) (4.64.0)
Collecting hydra-core<1.1,>=1.0.7
  Downloading hydra_core-1.0.7-py3-none-any.whl (123 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 123.8/123.8 KB 28.1 MB/s eta 0:00:00
Collecting torchaudio>=0.8.0
  Downloading torchaudio-0.12.1-cp38-cp38-manylinux1_x86_64.whl (3.7 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 3.7/3.7 MB 89.5 MB/s eta 0:00:00
Collecting regex
  Downloading regex-2022.9.13-cp38-cp38-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (772 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 772.3/772.3 KB 96.4 MB/s eta 0:00:00
Collecting torch
  Downloading torch-1.12.1-cp38-cp38-manylinux1_x86_64.whl (776.3 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 776.3/776.3 MB 2.8 MB/s eta 0:00:00
Requirement already satisfied: cffi in /home/user/.local/lib/python3.8/site-packages (from fairseq==0.12.2) (1.15.0)
Collecting sacrebleu>=1.4.12
  Downloading sacrebleu-2.2.1-py3-none-any.whl (116 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 116.9/116.9 KB 31.7 MB/s eta 0:00:00
Collecting omegaconf<2.1
  Downloading omegaconf-2.0.6-py3-none-any.whl (36 kB)
Collecting antlr4-python3-runtime==4.8
  Downloading antlr4-python3-runtime-4.8.tar.gz (112 kB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 112.4/112.4 KB 29.0 MB/s eta 0:00:00
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
Requirement already satisfied: importlib-resources in /home/user/.local/lib/python3.8/site-packages (from hydra-core<1.1,>=1.0.7->fairseq==0.12.2) (5.7.1)
Requirement already satisfied: PyYAML>=5.1.* in /home/user/.local/lib/python3.8/site-packages (from omegaconf<2.1->fairseq==0.12.2) (6.0)
Requirement already satisfied: typing-extensions in /home/user/.local/lib/python3.8/site-packages (from omegaconf<2.1->fairseq==0.12.2) (4.2.0)
Collecting portalocker
  Downloading portalocker-2.5.1-py2.py3-none-any.whl (15 kB)
Collecting tabulate>=0.8.9
  Downloading tabulate-0.8.10-py3-none-any.whl (29 kB)
Collecting lxml
  Downloading lxml-4.9.1-cp38-cp38-manylinux_2_17_x86_64.manylinux2014_x86_64.manylinux_2_24_x86_64.whl (6.9 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 6.9/6.9 MB 115.8 MB/s eta 0:00:00
Collecting colorama
  Downloading colorama-0.4.5-py2.py3-none-any.whl (16 kB)
Requirement already satisfied: pycparser in /home/user/.local/lib/python3.8/site-packages (from cffi->fairseq==0.12.2) (2.21)
Requirement already satisfied: zipp>=3.1.0 in /home/user/.local/lib/python3.8/site-packages (from importlib-resources->hydra-core<1.1,>=1.0.7->fairseq==0.12.2) (3.8.0)
Building wheels for collected packages: fairseq, antlr4-python3-runtime
  Building wheel for fairseq (pyproject.toml): started
  Building wheel for fairseq (pyproject.toml): finished with status 'done'
  Created wheel for fairseq: filename=fairseq-0.12.2-cp38-cp38-linux_x86_64.whl size=11146014 sha256=fc64b6a49778b065e9c03895bb5ab914062ccd3d0f1a6b29f2228e86d4e4b749
  Stored in directory: /tmp/pip-ephem-wheel-cache-fauikr2e/wheels/02/25/51/b7408d62cd34b341d42457670a6d0fa6230dbe9081a4bca304
  Building wheel for antlr4-python3-runtime (setup.py): started
  Building wheel for antlr4-python3-runtime (setup.py): finished with status 'done'
  Created wheel for antlr4-python3-runtime: filename=antlr4_python3_runtime-4.8-py3-none-any.whl size=141230 sha256=bef97525bf1beb0ef16eab8e2b5ce266349e554caaf2802520143cc2dd5d1000
  Stored in directory: /home/user/.cache/pip/wheels/c8/d0/ab/d43c02eaddc5b9004db86950802442ad9a26f279c619e28da0
Successfully built fairseq antlr4-python3-runtime
Installing collected packages: bitarray, antlr4-python3-runtime, torch, tabulate, regex, portalocker, omegaconf, lxml, cython, colorama, torchaudio, sacrebleu, hydra-core, fairseq
Successfully installed antlr4-python3-runtime-4.8 bitarray-2.6.0 colorama-0.4.5 cython-0.29.32 fairseq-0.12.2 hydra-core-1.0.7 lxml-4.9.1 omegaconf-2.0.6 portalocker-2.5.1 regex-2022.9.13 sacrebleu-2.2.1 tabulate-0.8.10 torch-1.12.1 torchaudio-0.12.1
WARNING: You are using pip version 22.0.2; however, version 22.2.2 is available.
You should consider upgrading via the '/usr/local/bin/python -m pip install --upgrade pip' command.
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100   162  100   162    0     0    229      0 --:--:-- --:--:-- --:--:--   229

  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100    68  100    68    0     0     42      0  0:00:01  0:00:01 --:--:--    97
当前IP: 54.227.136.200
归属地: 美国 弗吉尼亚 阿什本
Defaulting to user installation because normal site-packages is not writeable
Collecting torchvision
  Downloading torchvision-0.13.1-cp38-cp38-manylinux1_x86_64.whl (19.1 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 19.1/19.1 MB 68.4 MB/s eta 0:00:00
Requirement already satisfied: pillow!=8.3.*,>=5.3.0 in /home/user/.local/lib/python3.8/site-packages (from torchvision) (9.1.1)
Requirement already satisfied: typing-extensions in /home/user/.local/lib/python3.8/site-packages (from torchvision) (4.2.0)
Requirement already satisfied: numpy in /home/user/.local/lib/python3.8/site-packages (from torchvision) (1.22.4)
Requirement already satisfied: requests in /home/user/.local/lib/python3.8/site-packages (from torchvision) (2.27.1)
Requirement already satisfied: torch==1.12.1 in /home/user/.local/lib/python3.8/site-packages (from torchvision) (1.12.1)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in /home/user/.local/lib/python3.8/site-packages (from requests->torchvision) (1.26.9)
Requirement already satisfied: charset-normalizer~=2.0.0 in /home/user/.local/lib/python3.8/site-packages (from requests->torchvision) (2.0.12)
Requirement already satisfied: idna<4,>=2.5 in /home/user/.local/lib/python3.8/site-packages (from requests->torchvision) (3.3)
Requirement already satisfied: certifi>=2017.4.17 in /home/user/.local/lib/python3.8/site-packages (from requests->torchvision) (2022.5.18.1)
Installing collected packages: torchvision
Successfully installed torchvision-0.13.1
WARNING: You are using pip version 22.0.2; however, version 22.2.2 is available.
You should consider upgrading via the '/usr/local/bin/python -m pip install --upgrade pip' command.
Defaulting to user installation because normal site-packages is not writeable
Collecting opencv-python-headless
  Downloading opencv_python_headless-4.6.0.66-cp36-abi3-manylinux_2_17_x86_64.manylinux2014_x86_64.whl (48.3 MB)
     ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 48.3/48.3 MB 52.1 MB/s eta 0:00:00
Requirement already satisfied: numpy>=1.14.5 in /home/user/.local/lib/python3.8/site-packages (from opencv-python-headless) (1.22.4)
Installing collected packages: opencv-python-headless
Successfully installed opencv-python-headless-4.6.0.66
WARNING: You are using pip version 22.0.2; however, version 22.2.2 is available.
You should consider upgrading via the '/usr/local/bin/python -m pip install --upgrade pip' command.
Defaulting to user installation because normal site-packages is not writeable
Collecting gdown
  Downloading gdown-4.5.1.tar.gz (14 kB)
  Installing build dependencies: started
  Installing build dependencies: finished with status 'done'
  Getting requirements to build wheel: started
  Getting requirements to build wheel: finished with status 'done'
  Preparing metadata (pyproject.toml): started
  Preparing metadata (pyproject.toml): finished with status 'done'
Requirement already satisfied: six in /home/user/.local/lib/python3.8/site-packages (from gdown) (1.16.0)
Requirement already satisfied: beautifulsoup4 in /home/user/.local/lib/python3.8/site-packages (from gdown) (4.11.1)
Requirement already satisfied: filelock in /home/user/.local/lib/python3.8/site-packages (from gdown) (3.7.0)
Requirement already satisfied: requests[socks] in /home/user/.local/lib/python3.8/site-packages (from gdown) (2.27.1)
Requirement already satisfied: tqdm in /home/user/.local/lib/python3.8/site-packages (from gdown) (4.64.0)
Requirement already satisfied: soupsieve>1.2 in /home/user/.local/lib/python3.8/site-packages (from beautifulsoup4->gdown) (2.3.2.post1)
Requirement already satisfied: idna<4,>=2.5 in /home/user/.local/lib/python3.8/site-packages (from requests[socks]->gdown) (3.3)
Requirement already satisfied: charset-normalizer~=2.0.0 in /home/user/.local/lib/python3.8/site-packages (from requests[socks]->gdown) (2.0.12)
Requirement already satisfied: urllib3<1.27,>=1.21.1 in /home/user/.local/lib/python3.8/site-packages (from requests[socks]->gdown) (1.26.9)
Requirement already satisfied: certifi>=2017.4.17 in /home/user/.local/lib/python3.8/site-packages (from requests[socks]->gdown) (2022.5.18.1)
Collecting PySocks!=1.5.7,>=1.5.6
  Downloading PySocks-1.7.1-py3-none-any.whl (16 kB)
Building wheels for collected packages: gdown
  Building wheel for gdown (pyproject.toml): started
  Building wheel for gdown (pyproject.toml): finished with status 'done'
  Created wheel for gdown: filename=gdown-4.5.1-py3-none-any.whl size=14933 sha256=288fbca3f928d3192d33266d54a45c215dd9e9bc6e5f578c7c57f06730e9f40e
  Stored in directory: /home/user/.cache/pip/wheels/8d/df/71/846b2aa0fabaac2af23fbc5214eeaa55f0616e9d1a05187d72
Successfully built gdown
Installing collected packages: PySocks, gdown
Successfully installed PySocks-1.7.1 gdown-4.5.1
WARNING: You are using pip version 22.0.2; however, version 22.2.2 is available.
You should consider upgrading via the '/usr/local/bin/python -m pip install --upgrade pip' command.
/home/user/.local/lib/python3.8/site-packages/gdown/cli.py:127: FutureWarning: Option `--id` was deprecated in version 4.3.1 and will be removed in 5.0. You don't need to pass it anymore to use a file ID.
  warnings.warn(
Access denied with the following error:

 	Too many users have viewed or downloaded this file recently. Please
	try accessing the file again later. If the file you are trying to
	access is particularly large or is shared with many people, it may
	take up to 24 hours to be able to view or download the file. If you
	still can't access a file after 24 hours, contact your domain
	administrator. 

You may still be able to access the file from the browser:

	 https://drive.google.com/uc?id=1-2KSdpfikTj9fnXjluuMOeFpguBrNyM2 

mv: cannot stat 'vqa_large_best.pt': No such file or directory
2022-09-22 07:43:37 | INFO | fairseq.tasks.text_to_speech | Please install tensorboardX: pip install tensorboardX
Traceback (most recent call last):
  File "app.py", line 11, in <module>
    from fairseq import utils,tasks
  File "/home/user/.local/lib/python3.8/site-packages/fairseq/__init__.py", line 33, in <module>
    import fairseq.criterions  # noqa
  File "/home/user/.local/lib/python3.8/site-packages/fairseq/criterions/__init__.py", line 36, in <module>
    importlib.import_module("fairseq.criterions." + file_name)
  File "/usr/local/lib/python3.8/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "/home/user/.local/lib/python3.8/site-packages/fairseq/criterions/ctc.py", line 21, in <module>
    from fairseq.tasks import FairseqTask
  File "/home/user/.local/lib/python3.8/site-packages/fairseq/tasks/__init__.py", line 136, in <module>
    import_tasks(tasks_dir, "fairseq.tasks")
  File "/home/user/.local/lib/python3.8/site-packages/fairseq/tasks/__init__.py", line 117, in import_tasks
    importlib.import_module(namespace + "." + task_name)
  File "/usr/local/lib/python3.8/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "/home/user/.local/lib/python3.8/site-packages/fairseq/tasks/multilingual_translation.py", line 20, in <module>
    from fairseq.models import FairseqMultiModel
  File "/home/user/.local/lib/python3.8/site-packages/fairseq/models/__init__.py", line 235, in <module>
    import_models(models_dir, "fairseq.models")
  File "/home/user/.local/lib/python3.8/site-packages/fairseq/models/__init__.py", line 217, in import_models
    importlib.import_module(namespace + "." + model_name)
  File "/usr/local/lib/python3.8/importlib/__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "/home/user/.local/lib/python3.8/site-packages/fairseq/models/speech_to_speech/__init__.py", line 7, in <module>
    from .s2s_conformer import *  # noqa
  File "/home/user/.local/lib/python3.8/site-packages/fairseq/models/speech_to_speech/s2s_conformer.py", line 13, in <module>
    from fairseq.models.speech_to_speech.s2s_transformer import S2UTTransformerModel
  File "/home/user/.local/lib/python3.8/site-packages/fairseq/models/speech_to_speech/s2s_transformer.py", line 22, in <module>
    from fairseq.models.speech_to_text import S2TTransformerEncoder
  File "/home/user/.local/lib/python3.8/site-packages/fairseq/models/speech_to_text/__init__.py", line 7, in <module>
    from .convtransformer import *  # noqa
  File "/home/user/.local/lib/python3.8/site-packages/fairseq/models/speech_to_text/convtransformer.py", line 23, in <module>
    from fairseq.models.speech_to_text.modules.convolution import infer_conv_output_dim
ModuleNotFoundError: No module named 'fairseq.models.speech_to_text.modules'