build error

The command '/bin/sh -c pip install -r requirements.txt' returned a non-zero code: 1

Build logs:

Step 1/30 : ARG PYTHON_VERSION
Step 2/30 : FROM python:${PYTHON_VERSION}
 ---> dd4ac8dff24c
Step 3/30 : RUN apt-get update && apt-get install -y git-lfs
 ---> Using cache
 ---> 7729677ef93b
Step 4/30 : RUN git lfs install
 ---> Using cache
 ---> 1e03b488749d
Step 5/30 : RUN apt-get update && apt-get install -y         ffmpeg         libsm6         libxext6         cmake         libgl1-mesa-glx
 ---> Using cache
 ---> c50e211b3d5c
Step 6/30 : COPY packages.txt /root/packages.txt
 ---> Using cache
 ---> 97c3b1f8c8f0
Step 7/30 : RUN apt-get update && xargs -r -a /root/packages.txt apt-get install -y
 ---> Using cache
 ---> 99e7d1d464eb
Step 8/30 : RUN useradd -m user
 ---> Using cache
 ---> d75b8d2628a7
Step 9/30 : USER user
 ---> Using cache
 ---> 76ebce1c6ccf
Step 10/30 : ENV HOME /home/user
 ---> Using cache
 ---> ee383af144a6
Step 11/30 : ENV PATH $HOME/.local/bin:$PATH
 ---> Using cache
 ---> 355d65076f47
Step 12/30 : WORKDIR $HOME
 ---> Using cache
 ---> a7822f2748d3
Step 13/30 : RUN mkdir app
 ---> Using cache
 ---> fbe0213f254b
Step 14/30 : WORKDIR $HOME/app
 ---> Using cache
 ---> db5fc0fb0be5
Step 15/30 : ARG PIP_VERSION=22.0.2
 ---> Using cache
 ---> 5bfa0711679b
Step 16/30 : RUN pip install pip==${PIP_VERSION}
 ---> Using cache
 ---> bcf7de88939c
Step 17/30 : RUN pip install         datasets         huggingface-hub
 ---> Using cache
 ---> 85a750f4ad87
Step 18/30 : COPY requirements.txt $HOME/app/requirements.txt
 ---> Using cache
 ---> 40ac5aa96308
Step 19/30 : RUN pip install -r requirements.txt
 ---> Running in bebf6f068670
Defaulting to user installation because normal site-packages is not writeable
Collecting git+https://github.com/alexsilesjim/StyleGAN2-GANbanales (from -r requirements.txt (line 2))
  Cloning https://github.com/alexsilesjim/StyleGAN2-GANbanales to /tmp/pip-req-build-j40o6lcs
  Running command git clone --filter=blob:none --quiet https://github.com/alexsilesjim/StyleGAN2-GANbanales /tmp/pip-req-build-j40o6lcs
  Resolved https://github.com/alexsilesjim/StyleGAN2-GANbanales to commit b7aaabd5c84b07007bec341e2ce51114b9e1a11e
  Preparing metadata (setup.py): started
  Preparing metadata (setup.py): finished with status 'done'
ERROR: Could not find a version that satisfies the requirement tensorflow-gpu==1.14 (from versions: 2.2.0, 2.2.1, 2.2.2, 2.2.3, 2.3.0, 2.3.1, 2.3.2, 2.3.3, 2.3.4, 2.4.0, 2.4.1, 2.4.2, 2.4.3, 2.4.4, 2.5.0, 2.5.1, 2.5.2, 2.5.3, 2.6.0, 2.6.1, 2.6.2, 2.6.3, 2.6.4, 2.7.0rc0, 2.7.0rc1, 2.7.0, 2.7.1, 2.7.2, 2.8.0rc0, 2.8.0rc1, 2.8.0, 2.8.1, 2.9.0rc0, 2.9.0rc1, 2.9.0rc2, 2.9.0)
ERROR: No matching distribution found for tensorflow-gpu==1.14
WARNING: You are using pip version 22.0.2; however, version 22.1 is available.
You should consider upgrading via the '/usr/local/bin/python -m pip install --upgrade pip' command.
Removing intermediate container bebf6f068670